1 Reply Latest reply on Jul 7, 2009 10:32 PM by rcrayons

    Help! CS3 system requirement question

    rcrayons

      Help! Does anyone know if I can install illustrator CS3 on my mac that has OSX 10.5.7 ? I know the requirements for CS3 say its for 10.4.8, but can it be installed on a higher system like mine? Urgent answer needed due to deadline.