8 Replies Latest reply on Oct 3, 2011 10:37 AM by Peter Grainge

    Adobe RoboHelp 8 Pop-up Issue

    CFitzSimon

      Since upgrading to Adobe RoboHelp 8 from a former Macromedia version, the Topic Heading's will not display in the Pop-up windows. The pop-up headings worked in the older version.  The graphics that are in the heading appear but the text which is defined as Heading 1 does not.  Does anyone have a suggestion for correcting this problem?

        • 1. Re: Adobe RoboHelp 8 Pop-up Issue
          Peter Grainge Adobe Community Professional

          I have a problem with popups too since RH8. Mine are text only and nothing displays although moving the mouse over them can cause some text to appear.

           

          I have of course reported this and you should do the same.

           

          The more people who report a bug or request a feature, the more likely it is to be actioned. Please follow this link.

           

          http://www.Adobe.com/cfusion/mmform/index.cfm?name=wishform&product=38

           

          Meantime, they are OK in  IE8. Also in Firefox, I think. Unable to double check that right now.

           


          See www.grainge.org for RoboHelp and Authoring tips

          • 2. Re: Adobe RoboHelp 8 Pop-up Issue
            CFitzSimon Level 1

            Thank you for taking the time to respond, I have spent hours researching this issue.

             

            When I preview the topic in RH8 and select the pop-up, I too have the same results as you where none of the text is visible.  If I compile the file and view the same topic (which I'm sure there are others), the Header Text is the only missing text.  You are correct, when the Pop-up is opened in Firefox they are OK.  I am using IE7 which is the reason I noticed this problem to begin with.  I will do as you suggest and report this as a bug using the link you've provided!

            • 3. Re: Adobe RoboHelp 8 Pop-up Issue
              skolts

              While working on a recent project, I ran into what I think is a related issue, so I'm hoping someone has found the solution to this problem.

               

              I have created a couple of topics to serve as popup definitions. These topics use another CSS, which I named popup.css. In RoboHelp 8, the topics look fine. However, when I test the popup link (or compile it for that matter), the popup topic header is the only text that is visible. The second paragraph (which is normal body text that displays fine in other popups) is not visible at all. I cannot click and drag to select this non-visible text. When I do click and drag, there is some apparent scolling, but no additional text is selected. The HTML looks fine, and the CSS styles display fine in other popups so I'm at a loss. Can you offer any help?

              • 4. Re: Adobe RoboHelp 8 Pop-up Issue
                Peter Grainge Adobe Community Professional

                Take a look at Using RoboHelp 8 on my site. I think the answer was the headings having negative margins.

                 


                See www.grainge.org for RoboHelp and Authoring tips

                 

                @petergrainge

                • 5. Re: Adobe RoboHelp 8 Pop-up Issue
                  skolts Level 1

                  Thanks for your input. I've checked both CSS files for negative margins and there's not a single negative margin in any of my styles. Following along these same lines, I do have some margins specified by Points and a few others by Pixels, which may or may not cause a problem. I really don't think that's the issue because it's not caused any problems to this point. Here are the relevant styles:

                   

                  Heading 1: This text displays properly

                  H1 {

                            font-weight: bold;

                            font-size: 14pt;

                            margin-top: 9pt;

                            margin-bottom: 9pt;

                            color: #000080;

                  }

                  Normal: This text is not visible

                  BODY {

                            background-color: #ffffff;

                            font-family: Arial, san-serif;

                            font-size: 10pt;

                            color: #000000;

                  }

                   

                  P {

                            font-family: Arial, san-serif;

                            color: #000000;

                            margin-bottom: 9pt;

                            margin-top: 10pt;

                  }

                  Please let me know if there's anything else I can provide that may point to the root problem. Thanks.

                  • 6. Re: Adobe RoboHelp 8 Pop-up Issue
                    Peter Grainge Adobe Community Professional

                    I wouldn't have thought negative margins would cause the same problem but they did.

                     

                    Do you have the same problem

                     

                    1. If you use the same CSS in a new project?
                    2. If you use a different CSS in this project?

                     

                    You said earlier "The second paragraph (which is normal body text that displays fine in other popups)." A popup is a popup so what do you mean by other popups? When is the same content working and not working.

                     


                    See www.grainge.org for RoboHelp and Authoring tips

                     

                    @petergrainge

                    • 7. Re: Adobe RoboHelp 8 Pop-up Issue
                      skolts Level 1

                      Thanks Peter. I do not have the same problem if I use the same CSS in a new project. I do have the same problem if I use a different CSS in this project.

                       

                      I should have said "popup topics". In this case, I'm linking to popup topics that use a different CSS than my standard topics. Neither CSS files have negative margins specified in them.

                       

                      I have found a workaround (by simply duplicating an existing popup topic that worked properly and editing the content). The duplicated and edited popup topics display the text properly, which made me think the problem must have been in the html for the original popup topics rather than the CSS. However, there are no margin specs in this topic code so I'm not even sure about that.

                       

                      It's possible negative margins are at the root. I just don't know where they would have been spec'd. As it is, the text now displays properly so it's resolved for me.

                      • 8. Re: Adobe RoboHelp 8 Pop-up Issue
                        Peter Grainge Adobe Community Professional

                        What I meant was that I didn't think negative margins would cause my problem so what you thought wasn't the cause of yours couldn't be ruled out just because it seemed unlikely.

                         

                        It sounds like the problem related to something else in your project so the choices are rebuilding the project or doing what you are doing. I your choice is based on which is easiest.

                         

                        I suspect it is related to one the the popup problems shown in Using RoboHelp 8 on my site.

                         


                        See www.grainge.org for RoboHelp and Authoring tips

                         

                        @petergrainge