0 Replies Latest reply on Jul 9, 2009 4:38 PM by GordonSmith

    [svn:fx-trunk] 8499: TextAreaSkin no longer has a minimum size.

    GordonSmith Level 4

      Revision: 8499

      Author:   gosmith@adobe.com

      Date:     2009-07-09 16:38:35 -0700 (Thu, 09 Jul 2009)

       

      Log Message:

      ***********

      TextAreaSkin no longer has a minimum size.

       

      Glenn approved this change, despite the fact that the XD specs call for a minimum size of 36, because it was causing bugs such as SDK-16008 and SDK-20993. You might, for example, want a two-line TextArea whose height is less than 36 pixels.

       

      A non-zero minimum size was first introduced in revision 6808 to fix bugs SDK-19785 and SDK-19807. But the underlying cause of these bugs -- infinite invalidation loops caused by Scroller trying to figure out whether to put up scrollbars or not -- has been fixed in Scroller by Hans.

       

      This change is only part of the fix for SDK-20993; Scroller seems to be imposing a non-zero minimum size as well. Hans will make Scroller allow any size and hide its scrollbars if there isn't room for them.

       

      QE Notes: SDK-19786 and SDK-19807 should be retested

      Doc Notes: None

      Bugs: SDK-16008, part of SDK-20993

      Reviewer: Carol to review

       

      Ticket Links:

      ************

          http://bugs.adobe.com/jira/browse/SDK-16008

          http://bugs.adobe.com/jira/browse/SDK-20993

          http://bugs.adobe.com/jira/browse/SDK-19785

          http://bugs.adobe.com/jira/browse/SDK-19807

          http://bugs.adobe.com/jira/browse/SDK-20993

          http://bugs.adobe.com/jira/browse/SDK-19786

          http://bugs.adobe.com/jira/browse/SDK-19807

          http://bugs.adobe.com/jira/browse/SDK-16008

          http://bugs.adobe.com/jira/browse/SDK-20993

       

      Modified Paths:

      **************

          flex/sdk/trunk/frameworks/projects/spark/src/spark/skins/spark/TextAreaSkin.mxml