6 Replies Latest reply on Apr 10, 2010 1:00 PM by SamEdgar

    Effects Presets Not Found

    DavidSalahi Level 1

      My animation presets all give error messages like the following:

       

      ---------------------------
      After Effects
      ---------------------------
      After Effects warning: Bad argument: couldn’t find effect named ‘Radial Wipe Master Controls’
      Expression disabled.

       

      Error occurred at line 1.
      Comp: ‘Comp 1’
      Layer: 1 (‘DSC_0004.psd’)
      Property: ‘Transition Completion’

       

       

      The effects themselves work fine. I can manually set parameters. It's just that whenever I try to select any of the predefined presets they all fail with a message similar to this one. Same problem for all the effects that I've tried so far. Any ideas what causes this?

       

      (This is on a Windows 7 RC system.)

       

      David Salahi

        • 1. Re: Effects Presets Not Found
          Mylenium Most Valuable Participant

          Is your system set to English (en_US) and does AE run fully English? Presets and in particular the expressions used in them are language specific, so if you installed AE e.g. in French, but then run it in English, you will get that kind of errors. Also, if you run AE in English using the shortcuts from the Languages folder (or have created your own version of AfterFX.ex -L en_US), it may still use parts in your default language, which could be a problem with Windows seven. older versions of AE do the same on Windows Vista for instance, ands thus have a mix of menu entries in differnt languages... Check the points I mentioned, then report back.

           

          Mylenium

          • 2. Re: Effects Presets Not Found
            DavidSalahi Level 1

            Hi Mylenium,

            Thanks for your suggestions. I double-checked my Control Panel and my system is indeed set for English (US). As for After Effects, that should also be using English. I don't recall if CS4 asked about language when I installed it but if it did, I would certainly have selected English. It was basically a default install. And I definitely haven't created a customized language installation. Not sure where to look in CS4 to confirm language settings but all apps are displaying menus, dialogs, etc. as usual in English.

             

            Any other ideas?

             

            David Salahi

            • 3. Re: Effects Presets Not Found
              Mylenium Most Valuable Participant

              No, not really. I'm ready to bame this on being Windows 7 specific. Just to be sure, can you check in Bridge and preview some of the presets? also, does Bridge correctly run in English? any other Adobe tools on the system? Do they show any language mishmash?

               

              Mylenium

              1 person found this helpful
              • 4. Re: Effects Presets Not Found
                DavidSalahi Level 1

                Actually, I looked more systematically at the problem and found that some of my presets do work correctly. It initially looked like none worked because it just happened that the handful that I had tried all had a problem. One of the effects that has presets that fail is Brightness & Contrast. When I try any of the three Bloom presets I get a message like this:

                 

                After Effects warning: Bad argument: couldn’t find effect named ‘BloomAmount’
                Expression disabled.

                 

                Error occurred at line 1.
                Comp: ‘DSC_0032’
                Layer: 1 (‘DSC_0032.jpg’)
                Property: ‘Brightness’

                 

                When I looked into this I discovered that the effect BloomAmount that the preset is looking for is not installed in AE. So, apparently, this preset depends on an effect that isn't present on my system for some reason. For comparison, I checked the Brightness & Contrast effect in AE running on my laptop under Vista and found that the Brightness & Contrast effect there doesn't offer the three Bloom presets that are shown on my desktop (under Windows 7). The three presets on my Win 7 box are Bloom, Bloom_Cool, & Bloom_Warm. On my laptop, Brightness & Contrast offer no presets.

                 

                My presets preview fine in Bridge. Of course, you can't look at the Brightness & Contrast Bloom presets in Bridge or any of the other effects presets (only the presets shown in the Animation Presets category in AE). Other CS4 apps work fine (Fireworks, Photoshop, Flash, Dreamweaver).

                 

                Thanks,

                David Salahi

                • 5. Re: Effects Presets Not Found
                  Mylenium Most Valuable Participant

                  The effect references not showing up could indicate that your PresetEffects.xml file (in the program directory) is damaged or missing or - tata - with the wrong language). It stores a number of parameters and expression controls used by the presets. If insdeed it is missing, simply copying it over from your other system should resolve your issues.

                   

                  Mylenium

                  • 6. Re: Effects Presets Not Found
                    SamEdgar

                    Hello

                     

                    I havr the same problem and I can't understand your last intervension I made a search for such file as EffectPreset.xml, but noting came up?

                     

                    please Help I am on a dead line And I would like to use my presets again.

                     

                    I have even re-install After Effect but with no posotive results

                     

                    macbook 2.8 intel 2 cores 4GB mac os 10.6.3