0 Replies Latest reply on Jul 13, 2009 7:52 PM by Beppo5

    Compontents within SWC are sudenly not showing

    Beppo5

      I have been working on a project for the past few days and recently ran into a strange and frusterating problem.  I have been creating assets in flash, buttons and the like, and exporting an swc to a folder in my flex builder actionscipt project.  I've done this before and it's always worked great.  At some point during the course of this project I renamed one of the movieclips in the flash file and though it showed up in the "code hints" as I typed, flex was not recognizing it (I was getting Type was not found or was not a complie-time constant: xyz ).

       

      After checking that the swc folder link was still in tact, I tried making a whole new flash file and copy pasting all of my movieclips into the new project but alas, somewhere in the porcess, flex stopped recognizing everything in the swc.  Further more I can't get this particular flex project to recognize ANY swc file I put in there.  I tried making a whole new actionscript project in flex and that did work, but I still can't get the old files working.  I've just wasted the better part of an evening on this and I'm about to jump out the window.  Anyone ever have a prblem like this?  Any one know what might be wrong?  Is there a solution?

       

      Thanks,

      Joe