14 Replies Latest reply on Sep 25, 2008 6:04 AM by Lugosi1984

    Trouble creating remote topic link

    Lugosi1984
      Hello,
      My organization uses several (approx 10) chm files for our help system. I am having trouble creating an remote topic link in one of the chm files. After I create the link and compile the project, then click on the link, I get the standard 'The webpage cannot be displayed' message. The funny thing is, I can create a link to a page in another of the chm projects just fine. I also tried recompiling the chm file that I am trying to link to, just in case there was a discrepancy there, but that wasnt it.

      Does anyone know what could be the cause of this?

      Thank you!
      Jim
        • 1. Re: Trouble creating remote topic link
          Level 2
          Jim,

          Welcome to the forums.

          Are all of the CHM files in the same folder? It is odd that you can link to one but not another. This would suggest to me that you have an error in the path or the file or topic name. Are there any unusual characters (spaces, #, !, etc.) in the file or topic name that you are trying to link to? This could also cause a problem.

          I would look in the true code at the link and then double check that the HREF="filename.chm::/topicname.htm" reference the actual names of your external CHM and its topic.

          John
          • 2. Re: Trouble creating remote topic link
            Lugosi1984 Level 1
            Hello,
            Thanks for the quick response! No, that doesnt seem to be the answer either. This is the actual link that is in the help file (the one that doesnt work)
            urlahlp.chm::/urla_overview/urla_overview.htm

            The truecode is the following:
            <a href="urlahlp.chm::/urla_overview/urla_overview.htm">URLA</a>

            When I look at the structure of the urlahlp.chm file, everything looks like it is depicted above, same directory structure and all.

            This is the first time that I have ever had a problem this vexing before. I even have another link elsewhere in my help file where I link to the urlahlp.chm file successfully, but I dont see a difference between the code.

            I may end up having to just not do the links that I want to if I cant get this one figured out.......Maybe an answer will come along some other time.
            • 3. Re: Trouble creating remote topic link
              Level 2
              Jim,

              Do you have Help Workshop installed? Or another tool you could use to test Help calls? Can you open the remote chm to this topic with another tool? Can you copy the link that works and paste it where the link is failing? Are you absolutely sure that the urlahlp.chm has the 'urla_overview' folder and 'urla_overview.htm' spelled correctly?

              John
              • 4. Re: Trouble creating remote topic link
                Lugosi1984 Level 1
                Thanks again for the response. Yes, I do have HTML Workshop installed, but I have never really used it that much before, so I will have to look through it (I have time today). Yes, I did check all of the links to make sure that the entire path was correct. I did use the interface to create the link, so I wouldnt think that there would be a problem there though (as opposed to if I had typed it by hand). I guess the problem lies somewhere in urlahlp.chm, but I cannot see what the problem would be. Thanks for the help.
                • 5. Re: Trouble creating remote topic link
                  Lugosi1984 Level 1
                  One other thing that I should note about this problem is that sometimes, I do not get the 'The webpage cannot be displayed' message. When I preface the link to the urlahlp.chm file with 'ms-its:' (as some of the links within our projects have, some do not), and compile, then click on the link, nothing happens, no page change or anything. I dont know if that makes the problem easier to solve or not........
                  • 6. Re: Trouble creating remote topic link
                    Tech Writer KC Level 1
                    When you created the link, did it import the topic into the project? Have you tried deleting any related imported files and redoing the link/reimporting those files?
                    • 7. Re: Trouble creating remote topic link
                      Level 2
                      Jim,

                      With Help Workshop you can go to 'Test' / 'HTMLHelpAPI' and enter in the call (using the command 'HH_DISPLAY_TOPIC', just as if were a remote application trying to open the help. If this doesn't work it means the problem is in the CHM you are trying to call, rather than the calling link. While that is not a lot of info, it is at least a start. The latest versions of RoboHelp may have a tool like this added.

                      The ms-its: prefix is a protocol (kind of like http: or ftp:) that allows a web page to open a page inside a compiled help file. It really shouldn't be in any of your topics but I don't think it would cause any problems.

                      John
                      • 8. Re: Trouble creating remote topic link
                        Pete Lees Level 2
                        Hi, Jim,

                        I've seen this problem before on a few occasions. In each of those cases, the problem was caused by the fact that the target HTML topic file had the same name as that of the internal folder that contained it ("urla_overview.htm" and "urla_overview" in your case). This seemed to throw the HTML Help viewer into confusion.

                        If it's straightforward to do so, could you try renaming the "urla_overview" folder to something else?

                        Pete
                        • 9. Re: Trouble creating remote topic link
                          Lugosi1984 Level 1
                          Thanks for that answer, Pete. I WISH that was the answer, but it seems that I have trouble getting ANY file from in that directory 'urla_overview', or any other directory in urlahlp.chm to work. In testing a few different scenarios, I was actually able to get a couple of different pages from urlahlp.chm to work (never the one that I wanted to work, or course), but I could never duplicate the steps needed to get to that point. The solution did involve the use of the 'ms-its' protocol prefix and sometimes I would have to delete the string '%3%3' that somehow got put into the middle of my call. I deleted that string with Notepad, as it didnt show up in Robohelp (I am using Version 7, by the way).

                          It looks like that may be another problem that I could have down the road, though! I will try to remember to keep an eye open for that one.

                          To TechWriter KC, yes.....I did try deleting the urlahlp.chm file from the directory, and recompiling it then reintroducing the file. I really really thought that was going to be the ultimate answer, but it wasnt. Fiddlesticks!!!

                          Thank you for all the ideas. I guess I can really count on the folks in this forum to help out! I even try to scan through myself to see if there is anyone else that I can help and sort of 'pay it forward' :)
                          • 10. Re: Trouble creating remote topic link
                            Lugosi1984 Level 1
                            And FINALLY, A Mickey Mouse solution...........

                            I finally found a sequence of steps that seems to work very well (I just knocked on my head for some wood....ha ha):

                            1. Highlight the link text.
                            2. Click the Insert Hyperlink button on the toolbar.
                            3. Use the down arrow to select Remote Topic.
                            4. Click the folder button and re-find the chm file that I want to use (I cannot use the one that is already there in the folder, even though it is the SAME one)
                            5. Navigate to the htm page that I want to link to.
                            6. Go up to the address bar and edit the link that I just created to add the 'ms-its:' to the beginning of the call.
                            7. Click the Save Component button (with the single diskette glyph), not the Save All button (with the stack o diskettes glyph). This step seems to be necessary for some reason.
                            8. Compile the project.

                            Now that I have gone through the trouble of posting this, of course, it will no longer work, but at least this will be a historical document to let me and everyone else know that it did work at one point in time :)

                            Yes, it seems a little Mickey Mouse club, but it does work consistently, so I will keep it up.

                            Thanks for the help!
                            Jim
                            • 11. Re: Trouble creating remote topic link
                              Lugosi1984 Level 1
                              as I suspected......the steps are no longer working....... :(
                              • 12. Re: Trouble creating remote topic link
                                Level 2
                                I was hoping someone like Pete would chime in - he's seen a lot. One of the first things I did was to create a project with identically named folders, topics, filename but it worked without a hitch.

                                Jim,

                                Did I read you right in that you can't link from any folder in the urlahlp.chm? But you can link to topics not in a folder? And you can link to folders in other .chms, no?

                                John
                                • 13. Re: Trouble creating remote topic link
                                  Lugosi1984 Level 1
                                  OK....final answer....

                                  The correct version of the link is:
                                  <a href="ms-its:urlahlp.chm::/urla_overview/urla_overview.htm">URLA</a>

                                  It finally works......

                                  All done here :)

                                  Thank you all.
                                  • 14. Re: Trouble creating remote topic link
                                    Lugosi1984 Level 1
                                    Hey John,
                                    Just a response to your last message. No, I was not able to link to anything in the urlahlp.chm file at all for some reason. I could, however, link to other chm files that we use. Given the solution that I found, that still makes no sense at all, but that is the way that it was. I loved Pete's answer, and I so much wish that was the answer to the whole deal (aside from the fact that would create a bit of work for me to rename folders and such) because that, at least, would have made a little sense. (buggy sense, but sense nonetheless)

                                    I just have to go in by hand with an external editor and make sure that the link appears as what I posted and everything seems to work OK.

                                    I dont know if this is a bug in the way that Robohelp works, or if there is something strange in the way that our environment here at my office is set up. As you said, and I have read the same in other places on the net, the 'ms-its' protocol prefix should not be necessary, but in many cases with our projects, it is necessary. This incident of mine could be another symptom of our environment, not a reflection on how Robohelp works, I just dont know.

                                    I am just very happy that the solution is found, and I will now document that solution for the rest of our staff so that WHEN it happens again we have an answer.

                                    Thanks again, all of you, for your help. You all went above and beyond to help out.