5 Replies Latest reply on Jul 17, 2009 1:44 PM by Gary__F

    Problem configuring remote server

    rcwidower Level 1

      The problem I'm having is that the various pathing dialogs in the Remote Server setup seem rather amibiguous. I have tried what seems like every combination of remote and local file paths, as well as various url strings. No matter what combination I can't seem to get the file to resolve to a url that works.

       

      Our current development configuration consists of a central server running Windows 2008 Web Server and ColdFusion 8.0.1. There are three of us using the machine, each developer having their own share on it. We each have our own set of Virtual Hosts running from the share, through IIS on said server.

       

      This has been a great setup for us as it allows for a nearly duplicate environment to our production configuration. However, I can't for the life of me get a remote server configuration working completely. I have a secondary dev machine I use in which I am running CF9 locally, and it works perfectly (I'm aware of people saying that eclipse really doesn't want to have you develop remotely.) We don't switch our main dev server to CF9 just yet, and we want to keep the centralized dev server, so remote server seems the way to configure things.

       

      It seems like the best scenario is to set up a server for each on of the virtual hosts I have configured. In the dialog I would set one up like:

       

      General Settings
      Server Name: foo-site.com

      Host Name: dev1.foo-site.com

       

      Other Settings

      WebServer Port: 80

      RDS User Name: my-username

      RDS Password: my-password

       

      Remote Server Settings

      Naming Port: 2910

      Username: admin-server-username

      Password: admin-server-password

      Document Root: (this is a confusing one, does it want a url? a local file path like my mapped drive "Z:\"? or the physical path on the server "C:\webroot\"? Could be a path relative to my eclipse install? Also, does it want a global path? or one related to this server config?)

       

      Mappings

      Local Path: (Again, similar confusion...should this be local to me, or the server? or maybe a url?)

      Remote Path: (Should this be a url, and if so should it be an absolute url to the local path listed above? And what it the Local Path is the root of the virtual host, should it then be the same as document root [which doesn't seem to work]?)

       

      Install Extensions

      Remote Server Web Root: (Should this be a physical file path? should be in relation to eclipse on my machine? or from the server?)

      Install Location: (This would depend on the remote server web root obviously)

       

      I keep trying different things, and always end up with either the CF Server Settings for a project telling me the project exists outside the web root, or the sample url looks like http://[hostname]/[projectname].

       

      Any help would be greatly appreciated.

        • 1. Re: Problem configuring remote server
          RamKulkarni Level 2

          Document root has to be a physical path on the remote server e.g. "C:\webroot". This is the path on the remote machine and not mapped path on the machine on which CF Builder is installed.

           

          In mappings, local path is the path on the machine on which CF Builder is installed. Remote path is the path on the remote machine, and not the URL.

           

          e.g. if CF is installed at D:\Coldfusion on remote machine and on the your local machine (where CF Builder is installed) you have corresponding files in C:\ColdFusion, then when setting up remote server, you would set Document root to D:\Coldfusion\wwwroot and then you would create a mapping with local path as C:\ColdFusion\wwwroot and remote path as D:\ColdFusion\wwwroot.

           

          CF Builder uses this information when you preview files and when you debug a file.

          • 2. Re: Problem configuring remote server
            rcwidower Level 1

            Great, that definitely gets the right URL to show up in the "sample url" field in "ColdFusion Server Settings." It still throws up this message when I try to preview the page; "Unable to resolve file on remote machine with mappings provided. Make sure the debugging file has corresponding mapping in server."

             

            Here's an example that uses the style of mappings I'm using:

             

            General Settings
            Server Name: foosite.com

            Host Name: dev1.foosite.com

             

            Other Settings

            WebServer Port: 80

             

            Remote Server Settings

            Document Root: c:\dev.wwwroot\foosite

             

            Mappings

            Local Path: z:\foosite

            Remote Path: c:\dev.wwwroot\foosite

             

            Install Extension

            Remote Server Web Root: c:\dev.wwwroot\foosite

            Install Location: c:\dev.wwwroot\foosite\extensions

             

            Almost there! Thanks again for any help

             

            Eric

            • 3. Re: Problem configuring remote server
              Kiran Sakhare Level 1

              Tell us the location of the file your trying to preview.  Seems the file your trying to preview is doesn't in the location of mappings you added in server.

               

              For example :-

              I have c:\work\site\preview.cfm to preview. The corresponding file in server is in C:\ColdFusion9\wwwroot\site\preview.cfm

              So you need to add mapping in server

               

              Local path = c:\work

              Remote path = C:\ColdFusion9\wwwroot

               

              or

               

              Local path = c:\work\site

              Remote path = C:\ColdFusion9\wwwroot\site

              • 4. Re: Problem configuring remote server
                rcwidower Level 1

                I think I just figured it out. I've been using periods in my folder names as it corresponds well with the domains. When I just tried one project without periods in the document root I was able to preview the file with no problems. Looks like eclipse doesn't like the periods.

                 

                Well, looks like I have to think about migrating the folders to new non-period containing ones.

                 

                Thanks for the help!

                 

                Eric

                • 5. Re: Problem configuring remote server
                  Gary__F Level 1

                  I found all the setup fields a little ambiguous too. More guidance is definately required for setting up a remote CF server. I only realised I should have selected port 8500 by accident after watching one of Ben Forta's videos! Why doesn't it pre-fill with the typical port number to help people get started? Better tooltips would go a long way to help.

                   

                  All our file paths have dots in the folder names. e.g. \\fileserver01\dev.mydomain.com\ and also \\fileserver01\beta.mydomain.com\

                   

                  Is this really a problem for Eclipse? Surely not? Well, it could explain the problem.