10 Replies Latest reply: Jun 21, 2010 9:14 AM by ccroix25 RSS

    Unable to create the temporary folder. Error 183 when starting Distiller

    SnoBoy Community Member

      New information discovered - see end of message!

      Full error message is (window title is Acrobat Distiller):

      "Unable to create the temporary folder

      Error: 183 - cannot create a file when that file already exists."


      I have no idea what file or what folder it is referring to. This is on an x86 Vista notebook and the message comes up when starting the notebook and also if you manually start Distiller 8. Updating did not help, nor did turning off the UAC, or running Distiller as Administrator. In the latter case, Distiller will open correctly, but the next time you need to use it, it fails. With the UAC turned off, the behavior is for it to show the Distiller window for a fraction of a second and close immediately. I also gave the user full rights to the C:\Program Files\Adobe folder and lower. Made no difference.


      Coincidental with this is that the PDFMOfficeAddIn.dll add-in will not enable in Word - when it is checked, and I hit OK, I get the message:

      "The connected state of Office Add-Ins registered in HKEY_LOCAL_MACHINE cannot be changed."


      All of this is going on when logged in as an administrator. I have seen folks post about this issue, but no answers that actually fiux the problem, just suggest what I have already tried. Anyone seen this one?


      The user is highly mobile, so I am not going to have a chance to work on her computer again until next week.


      NEW INFO

      I tried removing and reinstalling as administrator and the problem remains. However while trying to troubleshoot, I discovered some more details.


      The message is being thrown when acrotray.exe is started as a process in HKLM\Software\Microsoft\Windows\Current Control Set\Run and then tries to run acrodist.exe (which fails, BTW). If I don't let it run there and run acrotray,exe as administrator, then acrodist.exe runs as a process without an error. Additionally, stopping it from running in the registry, and then starting MS Word, the Acrobat add-in does load and even though there is an error thown, it still creates the PDF! I have other Vista 32 notebooks running various Acrobat versions with no problems.


      Another key thing I found out is that Acrobat started throwing the error after an HP Scanjet 8400 and its software were installed. I tried explicitly giving the user (already an administrator) full rights to the Acrobat, HP and Read IRIS directories. Did not help the problem. I have to think that there is some interaction there, but sure don't know what it is.