4 Replies Latest reply on Jul 31, 2009 8:07 AM by PeakDigital

    Flex Builder choked - need help please

    PeakDigital Level 1

      I had to go out of town for a few days so I installed Flex Builder 3 on my MacBook, downloaded and installed Flex SDK 3.3 (Since that is what I have been building on, on my office Mac), created an exported .zip of my major project files on my office Mac, copied it to the MacBook and set off on my trip.

       

      When I set up the MacBook to start work, things looked OK at first, until I tried to switch to design mode. It popped up an error that "This component is based on ______, which is not a visual component. Switch to source mode to edit it" It did this for components based on Grid, Canvas, HBox and more.

       

      I was stumped, and miles from an Internet connection to be able to do research. FInally I decided maybe my install of SDK 3.3 was corrupt. I reset in the project prefs to use SDK 3.0 and ... everything worked perfectly!  I did what I needed to do for the rest of the weekend and returned home.

       

      Now, I just tried to export my project as a Flex Project Archive on my MacBook. It resulted in a 24K .zip file - basically empty - that can't be used. So, I just renamed my primary project folder on the office Mac to hide it from Flex Builder, then copied all the files, including the hidden .flexproperties, .project and .actionscriptproperties,  from the MacBook onto my office Mac in a new project folder named the same and in the same location as previously. The transfer appeared to be successful.

       

      Now, on my office Mac, I am getting the message "An unknown item is declared as the root of your MXML document.Switch to source mode to correct it." This happens every time I try to switch to Design view, regardless of what component is used in the MXML doc.

       

      After many attempts at figuring out and fixing the problem I tried setting the project properties to utilize SDK 3.1. Once that process was complete, then I went into properties again and set it to 3.3.  It appears that I may have succeeded in restoring it to usability, but I'm not confident in that yet.

       

      Can anyone give me some insight into the cause and fix of this problem? Especially the failure of Flex Builder to create a viable .zip archive file? I will be needing to move the project back and forth between my computers quite a bit for travel in the next few months.

       

      Thanks.

      Paul