4 Replies Latest reply on Jan 20, 2011 9:56 AM by mojosenv

    "File not found: /Adobe_CFC_Generator/handlers/index.cfm"

    Ratsnackbar Level 2

      Ok I know this is going to turn out to be something silly.  But I cannot seem to get the Extensions to function.  I get the error "File not found: /Adobe CFC Generator/handlers/index.cfm" every time I attempt to use the CFC generator and similar errors for ther other extensions.

       

      I am using ColdFusion 9 Standalone Server and Apache 2.2.x on Windows XP SP3.

       

      ColdFusion is installed to:  C:\ColdFusion9

      Apache is installed to C:\Apache

      The Apache Documents folder is mounted to C:\wwwroot rather then the traditional htdocs.

       

      All Websites are within the wwwroot and set up using VirtualHosts and all sites run off of port 80.  I am using a hosts file to make the domain names back to this development system.

       

      When installing coldfusion the document root was set to C:\wwwroot thus the CFIDE is within that director.

       

      The Server is configured to use the local systems hostname on Port 80.

      Server Home = C:\coldfusion9

      Document Root = C:\wwwroot

      Version 9.0.X

       

      I have access to the RDS Dataview and fileview.

       

      I have attempted to use a virtualhost mapping to the extensions already.  I have also changed the name of the folder to Adobe_CFC_Generator and set a host setting for it to resolve to the systems static ip address and then used the virtualhost mapping.  No luck so far.  The files are there in the c:\wwwroot directory.  When I first looked a the settings for the extension it stated that the path was C:\wwwroot/Adobe CFC Generator. (Note the slashes.)  So I modified the servers document root to be C:/wwwroot.  Still no go.

       

      The extensions install location is currently C:/wwwroot/Adobe_CFC_Generator.

       

      Again I am sure this is something stupid simple.  Anyone have any idea what I am missing?

        • 1. Re: "File not found: /Adobe_CFC_Generator/handlers/index.cfm"
          Evelin Varghese Level 2

          Hi,

          Can you try few options,

           

          1.Rename the Adobe_CFC_Generator back to Adobe CFC Generator (Remove '_' )

           

          The extension details showing path as C:\wwwroot/Adobe CFC Generator is fine.

           

          2.Can you check what is the port of the server?

           

          The url for the extension is created using the ip and port provided in the server wizard.

           

          3.Can you try to accessthe same from browser?

               htttp://<serverip>:<port>/Adobe CFC Generator/handlers/index.cfm

          This url should not give  file not found excpetion.It will show some other error which is fine.

          If you are able to access this url properly then,

               Verify the server associated with the extension is same.(Preferences->ColdFusion->Extensions-> Adobe CFC Genereator -Active Server)

               Verify the port and ip of teh active server listed in the list of servers.

          If the url listed above is showing file not found exception,then the handlers files might have benn deleted some how.

           

          Check these and let us know.

           

          Thanks

          Evelin

          • 2. Re: "File not found: /Adobe_CFC_Generator/handlers/index.cfm"
            Ratsnackbar Level 2

            I did each.  The files were accessable.  However it still would not function and then I noticed that in the application log file there was a note that the location it was looking for the files were in the CFIDE directory.

             

            So I copied the folders into that directory and mode no other changes and Bing!  It worked.

             

            This may be related to my development setup.  It is perhaps not a normal setup.  I have apache, cf9 and the wwwroot folder all off the root of the c: drive.  I use a hosts file to map the actual IP address of my system to the domain names rather then using the loopback.   Apache uses virtual hosts to locate each site.   When coldfusion is installed I use that wwwroot to place the cfide directory.

             

            The error that it was showing in the application log was:

            "Error","jrpp-9","07/22/09","20:45:11",,"File not found: /Adobe_CFC_Generator/handlers/index.cfm The specific sequence of files included or processed is: C:\wwwroot\CFIDE\Adobe_CFC_Generator\handlers\index.cfm'' "

             

            The Adobe CFC Generator was attempted both with and without spaces.  The CFIDE directory being in the path even though the actual install location was C:\wwwroot\Adobe_CFC_Generator seemed a little odd so I tried simply locating the generator files in the CFIDE and everything seems to be working.

             

            Also note that I had attempted to create a mapping to the Adobe CFC Generator files in ColdFusion and through a VirtualHost and both did not work because of the spaces in the name.  Which Is why I tried the _'s.  It still did not work though.

             

            Not sure if this is a bug or (more likley) that my configuraiton is just odd but as long as it continues to work I am cool with it.

             

            Any thoughts?

            • 3. Re: "File not found: /Adobe_CFC_Generator/handlers/index.cfm"
              Ratsnackbar Level 2

              Oh I should also note that this was a CF Builder Pluggin installation into Flash Builder 4 Beta.  That may have had some effect.

              • 4. Re: "File not found: /Adobe_CFC_Generator/handlers/index.cfm"
                mojosenv

                Relocate to /CFIDE/. Money. Thanks, years later!!!