0 Replies Latest reply on Jul 23, 2009 7:28 AM by Jeff Wilker

    Flash/Flex Buider versions &  Error #1053: Illegal override

    Jeff Wilker

      I recently upgraded to FlashBuilder 4, rebuilt my FlexBuilder 3.2 apps, and continually hit "Error #1053: Illegal override" runtime errors.  I had to rebuild all dependent libraries with FB4 to get things to work.

       

      Based on http://bugs.adobe.com/jira/browse/SDK-14464 (second comment from bottom), it appears that the Adobe best practice is that all code should/must be compiled with the same version of FB.

       

      Does anyone know of any way to workaround this limitation?  Furthermore, how is it possible for 3rd party vendors to provide Flex libraries without also providing source code?

       

      Jeff