0 Replies Latest reply on Jul 23, 2009 1:18 PM by jones_a_h

    Can't get example component RandomWalk working in QTP

    jones_a_h

      I've been trying to get the sample RandomWalk component working in the QTP environment.

       

      I'm using Flex Builder 3, SDK3.2, QTP9.5 and I've tried it under QTP10 too. I've tried Flash Player 9 and Flash Player 10.

       

       

      I'm building with static linking of the automation libraries (-include-libraries) and in the same build I also include the delegate class (-includes RandomWalkDelegate).

      I've tried this as part of of Flex Builder AND using the AntTasks / Ant build script approach.

       

      I've put the class definition file into the QTP Flex Plugin install folder.

       

      When I use QTP's Object Spy, it finds the top level of the custom component FlexRandomWalk but it cannot see the child Label's used to render the graph...they show up as WinObject's.


      I've also been able to determine that the numAutomationChildren property is returning the correct number of children (I just added this property to the class definition file to expose it in QTP).

       

      So everything appears registered properly with QTP and its seeing the custom component but NOT its children.

       

      This is the stock example for custom component instrumentation with QTP...and I can't get it to work.

       

      Has any one been able to get it to work?

       

      What might I be doing wrong? Something with my build configuration?

       

      Any help would really be appreciated.

       

      Huw

       

      This is how I'm building the RandomWalk app...

       

                  <includes symbol="RandomWalkDelegate"/>

       

                  <compiler.include-libraries dir="${FLEX_HOME}/frameworks/libs" append="true">
                      <include name="automation.swc"/>
                      <include name="automation_agent.swc"/>
                      <include name="automation_dmv.swc"/>
                      <include name="qtp.swc"/>
                  </compiler.include-libraries>