5 Replies Latest reply on Jul 29, 2009 11:26 AM by Atmosfera

    Problem with Log In and SSI from list

    Atmosfera Level 1

      Hi there, good afternoon!

       

      Ive one doubt about something that probably I'm doing wrong, see, if you go to:

       

      http://www.perssimon.com/beta/index.php

       

      and try to log in with username: john password: doe

       

      everything goes fine, then you can cose your session by clickin on close, now, try with other credentials, it should redirect to an error page, but is not, is just sticking in the home page, that login box is loaded from a simple server side include, then, the home page contents, the user area and the error area is been loading from a server side include from list, for some reason the login is not redirecting to the error page but is working properly when the credentials are the right ones, any idea?

       

      I'm attaching some files, included the includes folder, I'm been struggling with this the last 2 days and I can't see where the error is.

       

      Hope somebody can help.

       

      Best regards!

       

      Arturo

        • 1. Re: Problem with Log In and SSI from list
          DwFAQ Level 4

          Dreamweaver -> Insert -> Developer Toolbox -> Control Panel -> Login Settings -> User Levels

           

          redirect on success:

          redirect on fail:

           

          Make settings, click OK

           

           

          On a side note: you should add a show if user is logged in SB from Developer Toolbox -> Condition Regions ->Show If User Is Logged In and add an else condition where you'd put your login form so that when a user is logged in there is no login form. I logged in with un/pw and I didn't think I was logged in at first because the login form was still there after logging in.

          • 2. Re: Problem with Log In and SSI from list
            Atmosfera Level 1

            Actually, I did it, but is still not working, that was the first thing I checked when I noticed the problem, attached a screen capture of that dialog box.

             

            And yes, thanks for the suggestion, I'm just waiting to have that thing fixed in order to do the rest of pending things.

             

            Thanks so much!

             

             

            Arturo

            • 4. Re: Problem with Log In and SSI from list
              DwFAQ Level 4

              There is no need to bump a discussion that is less than a day old. Your thread was only the third down the list when you needlessly bumped it.

              • 5. Re: Problem with Log In and SSI from list
                Atmosfera Level 1

                Looking at my code I think I found something, and I think it comes from the SSI, I'm holding the login box at top as an server side include, anyway, once the page is rendered online, I found this

                 

                    

                 

                My question is, all this code shouldn't be placed in the had tag not in the body tag?

                 

                Any comment?

                 

                Thanks a lot

                 

                Arturo

                 

                <body>

                <div align="center">

                <link href="/DWCS3/Ramesh/loginStyles.css" rel="stylesheet" type="text/css" />
                <link href="/DWCS3/Ramesh/includes/skins/mxkollection3.css" rel="stylesheet" type="text/css" media="all" />
                <script src="/DWCS3/Ramesh/includes/common/js/base.js" type="text/javascript"></script>
                <script src="/DWCS3/Ramesh/includes/common/js/utility.js" type="text/javascript"></script>
                <script src="/DWCS3/Ramesh/includes/skins/style.js" type="text/javascript"></script>
                <script src="/DWCS3/Ramesh/includes/tng/scripts/FormValidation.js" type="text/javascript"></script>
                <script src="/DWCS3/Ramesh/includes/tng/scripts/FormValidation.js.php" type="text/javascript"></script>
                <script type="text/javascript">
                  KT_FVO['kt_login_user'] = {required: true, type: 'text'}
                  KT_FVO['kt_login_password'] = {required: true, type: 'text'}

                  KT_FVO_properties['noTriggers'] += 1;
                  KT_FVO_properties['noTransactions'] += 1;
                </script>