2 Replies Latest reply on Aug 4, 2009 1:38 PM by Tempeste

    WYSIWYG Display in Multi-Author Environment

    Tempeste

      We are using a multi-author project that is continually generated as a KB.  We are using RSC and RHx7.  I am the only author having a bizarre problem with ONE topic out of over 600. 

      I have an issue with a page that when opened in RoboHelp comes up blank for me in WYSIWYG mode (and code body is just a blank <p>), but the other two authors see the WYSIWYG and code as it should be.  When I preview the topic though, it displays the topic AS IT SHOULD BE.

      Closing RoboHelp and even rebooting does not resolve the issue.  I’ve deleted my local version and replaced it with the RSC version, but still no joy.  I’ve worked with the other authors and we’ve done multiple “tricks”(overwrite local, overwrite db code, false updates, etc.) to try and fool it, but each one winds up transferring the bad code to other authors. 

      Thank you for any help you can provide.  Code snippets are below.

      Leah

       

      The RoboHelp Design view, when I view the HTML code for said page, shows only a truncated version of the code:

      <!doctype HTML public "-//W3C//DTD HTML 4.0 Frameset//EN">

      <html><head>

      <meta name=template content="Issues Template.htt">

      <meta http-equiv=content-type content="text/html; charset=utf-8">

      <meta name="build tags" content=SD>

      <meta name=topic-status content="Ready for Review">

      <meta name=topic-check-list content="First Draft,Added To TOC,Links,Index keywords,See Also keywords,Images,Browse Sequences,Tested,Finalized,Ran Smart Index">

      <meta name=generator content="Adobe RoboHelp - www.adobe.com">

      <meta name=generator-major-version content=0.1>

      <meta name=generator-minor-version content=1>

      <meta name=filetype content=RoboHelp>

      <meta name=filetype-version content=1>

      <meta name=page-count content=1>

      <meta name=layout-height content=486>

      <meta name=layout-width content=1008>

      <title>Avaya Issues</title>

       

      <link rel=StyleSheet href=default.css>

       

      <script type="text/javascript" language=JavaScript x-save-method=compute-relative

      src="showhide.js"></script>

       

      </head>

      <body>

      <p> </p>

      </body>

      </html>

       

      When the file code is viewed by the same author using RoboSource, it shows the full html coding (not truncated like in RH’s local copy).  It includes the heading  code, and continues with:

      </head>

      <body>

      <robohelp><script type="text/javascript" language=JavaScript1.2 src="ehlpdhtm.js"

      x-save-method=compute-relative></script>

      <script type="text/javascript" language=JavaScript1.2>

      <!--

      if( typeof( InitEffects ) != 'function' ) InitEffects = new Function();if( typeof( InitTrigger ) != 'function' ) InitTrigger = new Function();if( typeof( FilePopupInit ) != 'function' ) FilePopupInit = new Function();if( typeof( TextPopupInit ) != 'function' ) TextPopupInit = new Function();

      //-->

      </script>

       

      </robohelp>

      <robohelp><form>

      </robohelp>

       

      <div class=x-popup-text id=POPUP322352710  style='display: none; position: absolute' >…

       

        • 1. Re: WYSIWYG Display in Multi-Author Environment
          Amebr-ke0mH4 Level 2

          Have you got all the RH7 patches installed? There was a problem fixed in 7.0.1 that sounds similar to what you are experiencing. If you haven't patched your version yet, I'd recommend getting all of the patches.

           

          See snippet 14 on Peter Grainge's site for the blank topic issue, and snippets 23, 31 and 34 for what's in the patches.

           

          http://www.grainge.org/pages/authoring/rh7/using_rh7.htm

           

          Also note issue #20 in the 7.0.1 patch notes - if you are affected by this, I believe you'll have to fix it manually, unless you can afford to go back to a pre-upgraded version of your project and upgrade once you've installed all the patches. If you can't go back, which is likely if you've all been working on the project, I think it should just be a case of find and replace across your HTML files - you should be able to do a search on the forums for it, or maybe Peter or Rick will chime in with additional information if it is a problem for you.

           

          HTH,

          Amber

          • 2. Re: WYSIWYG Display in Multi-Author Environment
            Tempeste Level 1

            Thank you Amber, this was the issue exactly.  In the past, I had issues with receiving the updates due to a Firefox setting, and it was tabled for later.  I fixed the setting, got the update (installed the 7.0.1 patch) and rebooted.  Issue resolved, and here we are with a full document again! Thank you very much for your help!

             

            Leah