2 Replies Latest reply on Jul 28, 2008 8:33 AM by german01

    Projector doesn't load sounds from SWFs

    german01 Level 1
      I'm having troubles developing a projector.exe
      I have a folder with subfolders.
      I created a Master_Temple.exe out of subfolders.
      This Master_Template creates an empty movie clip (holder) where all SFWs from subfolders are loaded.
      Master Template has buttons that load movies

      CODE
      on frame 1 of Master_Template

      stop();
      var mc1 = this.createEmptyMovieClip("master_1", this.getNextHighestDepth());

      BUTTONS

      // To make sure previous movie is unloaded//
      on(press){
      unloadMovie("master_1");
      }
      //To load the new movie below the navigation bar, which is 80 pixels height//
      on (release) {
      mc1.loadMovie("Movies/History _Spanish_Language_2008.swf");
      master_1._x =0;
      master_1._y =81;
      }


      CODE SWFs - EXAMPLE - History_Spanish_Language_2008

      // This is one the movies with audio. When the audio is a single sound, it works when loaded to Master_Template//
      //This code is on main timeline//

      stop();
      my_Sound = new Sound(this);
      my_Sound.attachSound("p2.mp3");
      my_Sound.start();

      The sample above, has several movie clips with nested movie clips.

      Example: MovieClip Page3 has five buttons. Each button calls a sequence of sounds.

      //this code is on button. This code works, and p5b.mp3 plays on Master_Templatet//
      on(press){
      stopAllSounds();
      gotoAndStop("basque");

      }
      on(release){

      mySound =new Sound(this);
      mySound.attachSound("p5b.mp3");
      mySound.onSoundComplete =function(){
      _root.page3.Basque.gotoAndPlay("dos");
      }
      mySound.start();

      }

      PROBLEM
      //Only the first sound plays. The second doesn't//

      Movie Clip Page 3 has nested the MovieClip Basque.

      MovieClip Basque has these sounds on its timeline

      mySound = new Sound(this); // this sound works//
      mySound.attachSound("p6a.mp3");
      mySound.onSoundComplete = function (){
      mySound1 = new Sound(this); // this sound does not play//
      mySound1.attachSound("p6b.mp3");
      mySound1.onSoundComplete =function(){
      _root.page3.Basque.gotoAndStop("uno");
      }
      mySound1.start();
      }
      mySound.start();



      PLEASE TELL ME HOW TO SOLVE THE ISSUE OF LOADING SOUNDS TO Master_Template.exe

      Thanks for your help.

      German
        • 1. Re: Projector doesn't load sounds from SWFs
          Level 7
          Try

          mc1.loadMovie("Movies\\History _Spanish_Language_2008.swf");


          --
          Regards
          FlashJester Support Team

          e. - support@flashjester.com
          w. - www.flashjester.com

          "This has been one of the most impressive and thoroughly pleasant
          experiences of customer support I have ever come across - astounding!"
          Director - hedgeapple

          • 2. Re: Projector doesn't load sounds from SWFs
            german01 Level 1
            Thanks for replying.

            I tried what you suggested, but didn't work.

            Something I noticed is that all the sounds that are on the main timeline of the loaded movie work. However, cases like the one I am dealing with are nested in movie clips.

            For instance, movie clip basque, has nested another movie clip Basque.

            sounds on basque (first movie clip) play
            sounds on Basque(nested movie clip in basque) the first sound works, the second and other sounds don't work.

            Do you think this may be an issue with projector and flash player versions?

            Thanks