19 Replies Latest reply on Aug 30, 2011 8:17 AM by m!cklauer

    Flash CS4 on Mac OS X: cannot publish movies

    septicman_NZ

      Hi all,

       

      Any movie whatsover (i.e. any file in any location on my drive) cannot be published (including test movie via Command-Enter) because I get this error:

       

      "Error creating SWF movie file.  Be sure the destination file is not locked or on a locked drive. Also, check that the file name is not too long."

       

      The file name isn't too long, and I am logged in as an administrator on the machine.  All folders I have tried to publish to are unlocked and I have read/write priveliges to them.  This is a new install of CS4 and has been updated to the very latest version (and it didn't work before the update, not does it work after).

       

      Believe me, this is NOT to do with my specific permissions.  This is a clean install of Flash CS4 Professional on a very new Macbook Pro running OS 10.5.7

       

      If anyone can make this work for me I shall do a dance of joy.

       

      Many thanks for ANYONE who can help!

       

      Glyn.

        • 1. Re: Flash CS4 on Mac OS X: cannot publish movies
          septicman_NZ Level 1

          Sigh... I am not holding out much hope for an answer here, because I can see the question's been asked a few times and there is not ONE decent answer (past "Check your publish settings")

           

          However I DID find something interesting: if I don't SAVE the FLA, I can publish.  As soon as I save though, can't publish.  That is, if I have an untitled never-been-saved FLA, it works.  As soon as it gets saved and gets a name (or is even saved as 'untitled') it won't publish.

           

          C'mon folks, who's up for this challenge?  If I can't get Flash to work I am gonna have to go to Silverlight!  And that would suck!

           

          Glyn.

          • 2. Re: Flash CS4 on Mac OS X: cannot publish movies
            septicman_NZ Level 1

            Meh, seriously.  This sucks.  I can't use Flash any more.

            • 3. Re: Flash CS4 on Mac OS X: cannot publish movies
              jendehaan Level 4

              You can save the files, correct? (it's specifically publishing that's the problem?)  If so, can you attach a file to the forums so I can see if I can reproduce locally on rfmy macs?  I haven't seen this on any of my macs or heard of a problem, and if it's definitely not the export location, locked drives, locked files, long file names (those are all ones I've seen before), I'm not sure what to suggest. The only thing I can think of is that some asset of the file is open (prior publish, etc), but it doesn't sound like that's the problem either. Possibly some other hardware or installation glitch. Could you also share the details about your Macbook Pro so I could try to find a very similar machine, if I can't reproduce on my own?

               

              Thanks, Jen.

              • 4. Re: Flash CS4 on Mac OS X: cannot publish movies
                Faisca1978 Level 1

                I'm having the same problem as Glyn, and I've got a brand new iMac OSX 10.5.7

                I'm also the admin, and it's just the worst with Fla. I was also having font problems with it, and I had to create a new admin user to be able to see my fonts.

                There's something really odd about this relationship between Leopard 10.5.7 and Flash CS4 (clean install as well).

                 

                I'm getting VERY frustrated, as FLA is a tool I use quite often...

                 

                Natalia

                • 5. Re: Flash CS4 on Mac OS X: cannot publish movies
                  Faisca1978 Level 1

                  Hi there,

                   

                  I was able to fix it by reading someone else's post in the forum (thanks to Webshawty5). This is what I did to fix it:

                  I created a new folder within the folder where my original files were, called it SWF, and in the publish setting options, I changed the path to point to this new SWF folder.

                   

                  That seemed to work. I don't know why it doesn't work any other way... but at least, it's publishing them. Then I just move my SWF files to the original folder and it replaces any old SWF files I had there.

                   

                  I know it's not ideal, but hey, IT WORKS!

                   

                  Phewww... I feel much better now. Hope this helps you too:)

                   

                  N.

                  • 6. Re: Flash CS4 on Mac OS X: cannot publish movies
                    vsalon-aMqHkc

                    Hi all,

                     

                    I'm using iMac (intel) 2.4 core 2 Duo, Mac os X 10.6.1 (Snow Leopard) and I'm having the same problem.

                     

                    I took the code sample "publishlive" from FMS 3.5 server (under ../Documentstion/samples) load it to

                    my Flash CS4. I've changed the connection to my FMS live folder and run it. I got  2 video:

                    my own live camera that seems very good, the other should have been play the stream back

                    from my server but instead I got only a frame (freeze image) of my video.

                     

                    I used the Administrator console with a debug option, and played the stream from there  and got the

                    same freeze image.

                     

                     

                    Adobe guys, do you have any idea what's going on here ???

                     

                    Thanks,

                    Alon

                    • 7. Re: Flash CS4 on Mac OS X: cannot publish movies
                      septicman_NZ Level 1

                      Hey all,

                       

                      No disrespect to the helpful Adobe employee (above) that came in and offered to help, but Adobe support took five calendar days to come back to me with any kind of attempt at an answer, so by that time I had given up and gone back to using my PC for Flash.

                       

                      However -- the problem has since fixed itself on my Mac.  WTF!?  Yes, really.

                       

                      The only things it could have been are:

                       

                      [1] I ran a diagnostic utility -- one of the ones that ships with MacOS, in the utilities folder -- and that seems to indicate an abnormality with my file permissions (generally, throughout the computer).  This is a Mac that was only a few weeks old and had very little other than CS4 installed, so it's possible it shipped that way.  I ran the repair and it actually seemed to fix up a lot of other odd issues I was getting (plenty of "you don't have permission to do that" type errors)

                       

                      [2] When I tried to activate my software with the registration key, it errored and said invalid key.  This is because I had installed trials with US English as the default (you know, just pressed 'ok' a lot) and the serial number I had was actually for an international English version.  There was a whole lot of complicated crap I needed to do (including several reinstalls) but I *believe* that it was already working by that stage.

                       

                      So -- to that end, I think people having this problem should consider it to be some kind of permissions problem.  Try running one of the standard Mac diagnostic tools to see if you might have the same issue.  But otherwise, pursue Adobe because this is obviously a bigger problem that just one person.

                       

                      Cheers, Glyn

                      • 8. Re: Flash CS4 on Mac OS X: cannot publish movies
                        corbin54

                        Same exact problem as septicman_NZ.  Please adobe, what's going on here?

                        • 9. Re: Flash CS4 on Mac OS X: cannot publish movies
                          chago1971

                          This is what worked out for me...

                           

                          1. Delete Flash's preferences (located in user/library/preferences/Flash CS3 Preferences  (or Flash CS4 Preferences)

                          2. In same folder... find/delete: Flash CS3 MRU  (or Flash CS4 MRU)

                          3. In same folder... find/delete: com.adobe.flash-9.0-en_us.plist

                           

                          4. If files are in Main HD. Get Info (Apple+I), and make sure that "everyone" is set to read & write (view screenshot below)

                          Picture 2.jpg

                           

                          5. If files are in external HD. Do this: Get Info (Apple+I), and at the very bottom of the info window, enable option "Ignore Ownership on this Volume" and then select "apply to enclosed items" from the pulldown menu.(view screenshot below)

                          Picture 3.jpg

                          ----------------->>>>>>

                           

                          Picture 4.jpg

                           

                           

                          6. Now try to export any swf from flash.

                          7. If problem persist.... In Flash's publish settings.... refresh the publishing paths by reselecting the destination location.

                           

                          I hope this works for u too ; )

                          • 10. Re: Flash CS4 on Mac OS X: cannot publish movies
                            HaakonFossen Level 1

                            This problem has been bugging me for some time too, and somewhat embarrassingly I discovered that not only the files, but also the folders they occur in needed to be unlocked. Once all folders involved were given read & write privilege, everything worked fine. Hope this is helpful to someone.

                            • 11. Re: Flash CS4 on Mac OS X: cannot publish movies
                              alexfranka

                              same thing was happening to me: a client gave me some files to work on and upon copying those files to my desktop I noticed the error whenever I wantet to publish. I solved it by going to the publish settings and changing the path—which was set by the client to publish in his machine and folder paths. Problem solved!

                              • 12. Re: Flash CS4 on Mac OS X: cannot publish movies
                                FlashLeaner Level 1

                                Ohhhhhhhhhhh i am afraid i am thinking about purchaginag the new mac book pro

                                only for developing the flash works. i think it

                                is better to be to stick with my brand new hp laptop which runs window 7

                                • 13. Re: Flash CS4 on Mac OS X: cannot publish movies
                                  lukdvr

                                  OK, your tip "tipped" me off to the sollution. Under publish settings "formats" change the path to where you want the files saved to simply the name of the file. It will publish where the original file lives. My file had a long path to a non exisitant folder so it couldnt publish there. Once removed it published fine.

                                  • 14. Re: Flash CS4 on Mac OS X: cannot publish movies
                                    feygraphica

                                    I am having this EXACT same error message, but it is happening whenever I make a movieclip within a fla file. Once I rotate through the error the movie clip appears as only an outline box on my stage, although opening the button (along with the error showing up again) is viewable and editable. Anything I try to do with the clip...edit, move, anything... the error pops on my screen repeatedly.

                                     

                                    This all started after I had a major crash and had to reinstall my system. My registration of CS4 Design Premium was messed up so I ran the Flex Licensing app as suggested by the Adobe site. All other programs work fine... just Flash is messed up. HELP!

                                     

                                    P.S... I did try the deletion of prefs, etc as suggested here... that did not work. Also, the file I am working on works fine on another computer running the same version of flash, so it has to be related to a missing or corrupted file I'm guessing, but I don't know which one. I even uninstalled and reinstalled flash to no avail.

                                     

                                    -------------------ANSWER FOUND PROBLEM FIXED!!!!--------------------

                                     

                                    After 10 days I finally found the solution that worked on twelvestone.com

                                     

                                    tonzeejee SOLUTION...

                                     

                                     

                                    Here's the solution if you're on a Mac running 10.5.X or later...

                                     

                                    QUIT Flash (don't CLOSE the window - QUIT the app completely (Flash menu next to the apple menu > "Quit")

                                     

                                    Browse to Macintosh HD/Users/"your user name"/Library/Application Support/Adobe

                                     

                                    Completely  delete the folder called "Flash CS4" or "Flash CS3", depending on which  version you're using. This means empty the trash.

                                     

                                    Re-launch Flash app - should be good to go.

                                    • 15. Re: Flash CS4 on Mac OS X: cannot publish movies
                                      konturq Level 1

                                      feygraphica/tonzeejee's approach did not work for me, bug still preventing me from publishing anything. (please note that following that advice will delete some of your flash settings, such as saved workspaces or other hotfixes installed to this directory).

                                       

                                      what I find more funny though is how I can sometimes publish again after I removed some random line of as code.

                                      also, I suspect it somehow has to do with the document class, because the movie file itself exports fine, if I change the Document Class to some non existent Class in the .fla, or, respectively and to same outcome change the flash player version to 8 or lower or as2.

                                       

                                      I'd also like to note that the error this message is intended for seems to not be the case (got admin rights to the file, the path is set, both default as well as full path don't work), thus the error report a bug.

                                       

                                      running cs3 on mac os x, fyi.

                                       

                                      screams for a fix!

                                       

                                       

                                      so, here's what I tried so far which got me to a some of what working file again:

                                       

                                      failed: change publish file types

                                      failed: change publish setting paths

                                      failed: delete flash settings folder

                                      failed: removed document class from .fla, renders swf, but naturally, the without as

                                      failed: renamed .as and class and edited .fla document class to new .as class

                                      failed: copy .fla and .as file

                                      failed: rename .fla and .as file

                                      failed: copied .fla and .as file, deleted original and renamed back to original name

                                      failed: copy whole folder

                                      worked: copied .fla and .as contents to new files ( cmd+a cmd+c -> new files -> cmd+v), deleted bugged files, saved copied files under original name to original folder

                                       

                                      so basically flash somehow manages to screw up the original .fla and/or .as file(s) so much, the only thing that helped with me was to completely copy all contents to new files, get rid of the old files, and the replace the deleted files with the copies. the downside to this is, obviously, , that you loose your layer and libary structure.

                                       

                                      what non-sense.

                                       

                                      Message was edited by: konturq

                                      • 16. Re: Flash CS4 on Mac OS X: cannot publish movies
                                        feygraphica Level 1

                                        I ended up throwing that entire folder away and haven't had a problem 

                                        since.

                                        • 17. Re: Flash CS4 on Mac OS X: cannot publish movies
                                          konturq Level 1

                                          not saying that generally throwing out that folder won't have effect, just saying for me it didn't help but destroy my workspace settings ,)

                                           

                                          posted above how I worked around not being able to export the corrupted file.

                                          • 18. Re: Flash CS4 on Mac OS X: cannot publish movies
                                            feygraphica Level 1

                                            oh well yeah... you'll have to reset those.

                                            • 19. Re: Flash CS4 on Mac OS X: cannot publish movies
                                              m!cklauer

                                              I had the same problem in CS3, and the answer was pretty simple (hope it helps others who run into this problem).

                                               

                                              ----

                                               

                                              In the publishing settings > Formats >  There is likely a destination location for your published file ... and it likely does not exist.

                                               

                                              This can happen if you change the name of your folders, or re-arrange them ... because the location no longer exists.

                                               

                                              Some people mentioned starting from scratch and no longer having an issue, the reason that would work is because the "new" destination would be generated along with the file.

                                               

                                              Took me a couple minutes to figure it out, hope it helps some folks

                                               

                                              formats-destination.jpg