12 Replies Latest reply on Nov 10, 2009 9:56 PM by InertiaTechLaw

    Can't incorporate 9.1.3 msp into msi install

    tworm

      I am trying to slipstream the 9.1.3 patch into my current 9.1.2 msi install  by using the command "msiexec /a [reader.msi file name] /p [Reader .msp file name]" The install finishes and creates 4 folders with all the files and even changes the timestamp on my msi file but the file size of my msi stays exactly the same size. Nothing else changes. When I try to run the msi file before pushing out through GPO I get the message below.

       

      Another version of this product is already installed. Installation of this version cannot continue. To configure or remove the existing version of this product, use Add/Remove Programs on the Control Panel."

       

      This is the exact same thing I did when I went from 9.1.0 to 9.1.2 and it worked fine for me. I even donloaded a fresh 9.1.0 executable and ran the command AdbeRdr90_en_US.exe -nos_o"Reader9" -nos_ne against the file to extract the msi. I then installed the 9.1.2 patch using "msiexec /a [reader.msi file name] /p [Reader .msp file name]" everything worked good, msi file changed sizes to show that the patch had been incorporated. I then ran the 9.1.3 patch against that msi file and it gave me the same results with message "Another version of this product is already installed".

       

       

      Anyone know what the problem might be?

        • 1. Re: Can't incorporate 9.1.3 msp into msi install
          bprentice Level 1

          I get a different error trying to update my 9.1.2 AIP using the command msiexec /a acroread.msi /p AcrobatUpd913_all_incr.msp /qb:

           

          The upgrade patch cannot be installed by the Windows

          Insteller service because the program to be upgraded

          may be missing, or the upgrade patch may update a

          different version of the program. Verify that the program

          to be upgraded exists on your computer and that you
          have the correct upgrade patch.

          • 2. Re: Can't incorporate 9.1.3 msp into msi install
            PumaKing1722

            Hi,

             

            I have the same problem and no real solution, but perhaps a workaround:

             

            I created a script which I run via GPO when starting the computer:

             

            start /wait msiexec /package Acroread.msi /update AdbeRdrUpd911_all_incr.msp;AdbeRdrUpd912_all_incr.msp;AdbeRdrUpd913_all_incr.msp /passive

             

            On my testmachine this works well. I'll test it on several others and if succesful I'll apply it to the whole organization.

             

            Perhaps this helps you.

             

            Update: That's no real solution, on other machines this didn't work correctly. So you can forget my post, sorry. Perhaps someone else has a real solution how to integrate the patch.

             

            Message was edited by: PumaKing1722

            • 3. Re: Can't incorporate 9.1.3 msp into msi install
              jay2057

              I was getting the same error when I ran the MSI. I have tried all the solutions that are found in this forum unsuccessfully. I created a GPO just to test it to see if I would get the same error, but I did not. When pushed by the GPO it installed as normal, removing 9.1.2. This is how I created my AIP.

              msiexec /a acroread.msi

              "msiexec /p AdbeRdrUpd912_all_incr.msp /a [Reader.msi file path]"

              "msiexec /p AdbeRdrUpd913_all_incr.msp /a [Reader.msi file path]"

               

              I have deployed it to several test machines successfully.

              • 4. Re: Can't incorporate 9.1.3 msp into msi install
                tworm Level 1

                I too had to give up trying to incorporate the msp file into the install. Instead I wrote a batch file with the following line included:

                 

                msiexec.exe /p "\\Shared Drive Location\AdbeRdrUpd913_all_incr.msp" /qn

                 

                and loaded via a startup script in the GPO.

                 

                This worked for me

                • 5. Re: Can't incorporate 9.1.3 msp into msi install
                  Terje-TTL

                   

                   

                  Tried to contact Adobe Support, reply was:

                   

                  Dear customer thanks for Contacting Adobe's Technical support
                  I cant help you with this matter as we dont support Adobe Reader.
                  For more information or help go to http://www.adobe.com/support/
                  Kind regards Adobe's Technical support
                  Nicolai.

                   

                  -------

                   

                  This however works for me:

                   

                  Acuire the files:

                   

                  acquire the latest available Adobe Reader (9.1.0) from Adobe. (Danish version would be: AdbeRdr910_da_DK.exe)

                   

                  Extract the files this way:

                   

                  Run the .exe file (do not proceed beyond running exe file)

                   

                  Files are now extracted to: C:\Documents and Settings\[YOUR USERNAME]\Local Settings\Application Data\Adobe\Reader 9.1\Setup Files

                   

                  Copy the files in the Setup Files directory to another directory.

                   

                  Continue installation

                   

                  Start Adobe Reader and open help->check for updates

                   

                  Press Settings button

                   

                  Check file placement (should be something like: C:\Documents and Settings\[YOUR USERNAME]\Local Settings\Application Data\Adobe\Updater6\Install\

                   

                  Press “OK”

                   

                  Press “Install now” (Do NOT proceed beyond this)

                   

                  Copy the files from C:\Documents and Settings\[YOUR USERNAME]\Local Settings\Application Data\Adobe\Updater6\Install\ to another folder (.msp files)

                   

                  You have now acquired the necessary files for installation.

                   

                  Install the files:

                  On a system with Adobe Reader 9.1.x already installed, the upgrade syntax is: msiexec /p AdbeRdrUpd913_all_incr.msp /QB!

                   

                  On a system without Adobe Reader installed, slipstream the msp into the msi with this syntax:

                  (Place the AcroRead.msi, data1.cab and .msp files in the same directory)

                  From that directory, run:

                  msiexec /a acroread.msi /p <PATH>AdbeRdrUpd913_all_incr.msp"

                  E.g: msiexec /a acroread.msi /p "C:\Documents and Settings\[YOUR USERNAME]\Desktop\Adobe\AdbeRdrUpd913_all_incr.msp"

                  Install with this syntax: msiexec /i AcroRead.msi /QB!

                   

                  Only “bug” I found: The slipstreamed msi can not be deployed if earlier version exists (MSI defines only versions 9.0.9 and earlier as upgradecodes). Workaround would be to use “uninstall first” option in SCCM environment.

                  Note on enterprise installation:

                  Disabling EULA by setting the following values in a transform file (.mst file):

                  Windows Registry Editor Version 5.00

                  [HKEY_LOCAL_MACHINE\SOFTWARE\Adobe\Acrobat Reader\9.0\AdobeViewer]

                  "EULA"=dword:00000001

                  "Launched"=dword:00000001

                  Disabling auto updates:

                  Windows Registry Editor Version 5.00

                   

                  [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Adobe\Acrobat Reader\9.0\FeatureLockdown]

                  "bUpdater"=dword:00000000

                   

                  [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Adobe\Adobe Acrobat\9.0\FeatureLockdown]

                  "bUpdater"=dword:00000000

                  Install syntax would be: msiexec /i AcroRead.msi transforms=AcroRead.mst /QB!

                  • 6. Re: Can't incorporate 9.1.3 msp into msi install
                    PumaKing1722 Level 1

                    Patching Adobe Reader seems to be a neverending story...

                     

                    For me, everything that Terje-TTL wrote worked when you don't have Adobe Reader installed. That means I can integrate the 9.1.3 patch in the installation so that I can install a fresh 9.1.3 version.

                     

                    BUT: I tried every hint that I found in here and elsewhere on the internet to patch an existing installation with version 9.1.1 but it fails whatever I try. On another post I found out that this seems to be a problem of 9.1.1 only. My problem is that at the moment all of you clients run on 9.1.1.

                     

                    So I created a vbs script that first checks whether 9.1.1 is installed and if so, uninstalls it and then installs the fresh 9.1.3 installation. I'm not really satisfied with the part after the uninstallation of 9.1.1 where the user has to press an OK-button to continue with the installation of 9.1.3 but I don't know how to figure out if the uninstallation process of 9.1.1 is already finished.

                    I tried to check whether "msiexec.exe" is running, but is seems to be run by other programs so that the script won't go further than. I also tried to check whether the program folder "%programfiles%\Adobe\Reader\Reader" is still existing but in some cases the uninstaller leaves it there so the script won't go further at that point. So I switched back to the messagebox where the user has to press OK when the uninstallation is finished. Perhaps someone has an idea to get this completely automated.

                     

                    Now here's the script (I put together some parts from different posts, so I didn't write it on my own completely):

                     

                    'Uninstall Adobe Reader 9.1.1 , Install 9.1.3
                    On Error Resume Next

                     

                    '**********************************************************************
                    const Reader911 = "Adobe Reader 9.1.1"
                    const HKEY_LOCAL_MACHINE = &H80000002
                    '**********************************************************************

                     

                    Set WshShell = WScript.CreateObject("WScript.Shell")
                    set WshShell = CreateObject("WScript.Shell")
                    Set FS = CreateObject("Scripting.FileSystemObject")
                    Set WMI = GetObject("winmgmts:")

                     

                    'find GUID
                    strComputer = "."
                    Set objReg=GetObject("winmgmts:{impersonationLevel=impersonate}!\\"&_
                        strComputer & "\root\default:StdRegProv")
                    strKeyPath = "SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall"
                    objReg.EnumKey HKEY_LOCAL_MACHINE, strKeyPath, arrSubKeys

                     

                    For Each subkey In arrSubKeys
                        InstalledAppName = ""
                        InstalledAppName = WshShell.RegRead("HKLM\" & strKeyPath & "\" & subkey & "\DisplayName")

                     

                        If InStr(InstalledAppName, Reader911) > 0 then
                        RawGUID = ""
                        GUID = ""
                            RawGUID = WshShell.RegRead("HKLM\" & strKeyPath & "\" & subkey & "\UninstallString")
                            GUID = Mid(RawGUID, instr(RawGUID, "{"), 38)
                            If GUID<>"" then
                           ' If Registry-entry "Adobe reader 9.1.1" was found then
                           
                                    WshShell.Run "msiexec /x " & GUID & " /passive /norestart /L*v c:\adobereader911.log"
                                    'Wait two minutes
                                    Wscript.sleep(120000)
                                    'Popup window to ask if the uninstallation is already finished
                                    Result = WshShell.Popup("Click on OK if the previous uninstallation is finished!!!", 180, "Installation Adobe Reader Security Update", 64)
                                    'install 9.1.3   
                                    WshShell.Run "msiexec /i AcroRead.msi TRANSFORMS=AcroRead.mst /passive /L*v c:\adobereader913.log"
                    Exit For
                            End If
                        End If
                    Next

                     

                    Perhaps this can help someone, ideas how to optimize it are welcome.

                    • 7. Re: Can't incorporate 9.1.3 msp into msi install
                      davehart9090

                      I found that the Update MSP's would only update the 9.1.0 public version of adobe.  Originally, I built an AIP (Administrator Install Point) using 9.1.0 and the 9.1.1 MSP. (Enterprise Version of the MSI.) Then I installed Adobe Reader to my users from there. None of the recent MSP's would work with the installed reader nor would they update the AIP. The Adobe installer notes says that the MSP won't update the AIP anyway.

                       

                      So I downloaded the reader again from Adobe (Ver 9.1.0) and the MSP's do work on that installed  version (I did not use an AIP but just installed Reader using the MSI).

                       

                      But my problem is that I have 6000 users with Reader 9.1.1. Searching the Internet and here, someone mentioned that WISE Studio could read MSP's but the version I have of WISE doesn't. But WISE Studio does have a patch building utiltiy which I used and now I have a patch (MSP File) that upgrades my 9.1.1 to 9.1.3 okay. To use WISE studio I built an AIP with my 9.1.1 and one with the Adobe 9.1.0. I upgrade the 9.1.0 to 9.1.3 using the MSPs.

                       

                      With WISE I pointed the patch creation tool to the two instances and voila, a patch was created. I had to ignore an error that said the versions were different (That is probably why the patches themselves won't run). I would share the patch but my version of 9.1.1 is heavily customized.

                       

                      Hopefully this information helps.

                       

                      Dave

                      • 8. Re: Can't incorporate 9.1.3 msp into msi install
                        PumaKing1722 Level 1

                        That's nice with the WISE Studio software but it's not free and I think for the most of us too expensive just to get an Adobe Reader patch working...

                        • 9. Re: Can't incorporate 9.1.3 msp into msi install
                          Terje-TTL Level 1

                          I agree. In theory, ORCA by Microsoft should work, but I never figured out how to work it. http://msdn.microsoft.com/en-us/library/aa372834(VS.85).aspx

                           

                          To create transform files (*.MST) Adobe Customization Wizard 9 http://www.adobe.com/support/downloads/thankyou.jsp?ftpID=3993&fileID=3727 can be used. You still have to know what you are doing however.

                           

                          Wouldn't it be fun, if Adobe just created a full standalone Adobe Reader version 9.1.3 for download, that upgrades all previous versions? Or does it make more sense that every sysadmin in the world creates his/her own version?

                           

                          Free software does not mean cost neutral. The time you spent to make it work is not free.

                          • 10. Re: Can't incorporate 9.1.3 msp into msi install
                            JackWFletcher

                            I slipstreamed the 9.1.1,9.1.2, and 9.1.3 updates into the msi package, and re-compiled it into an executable installer package. It is hosted at the following loaction

                             

                            http://www.filefactory.com/file/ah450a7/n/AdbeRdr913_en_US_exe

                            • 11. Re: Can't incorporate 9.1.3 msp into msi install
                              isfn

                              This is not a bug, it is this way by design. It's explained here:

                               

                              http://kb2.adobe.com/cps/498/cpsid_49880.html

                              • 12. Re: Can't incorporate 9.1.3 msp into msi install
                                InertiaTechLaw Level 1

                                It is the order in which you are patching.  You have to apply patches in the following order:

                                 

                                9.0.0  -->  9.1.0  -->  9.1.2  -->  9.2.0

                                 

                                Quarterly patches are the only ones that can be installed onto a AIP.  Security patches like 9.1.1 and 9.1.3 should never be installed to AIP.