7 Replies Latest reply on Aug 8, 2008 8:34 AM by Ken_Bruggeman

    Movie Clip rollover problem

    Ken_Bruggeman
      Hey everyone... I am creating a series of movieclip buttons in my flash file and I followed a tutorial to the DETAIL but for some reason when I rollover the mc button it isnt playing like it is supposed to... I am not sure why... I know you will need my .fla file, but not sure how to get it to you... Please help! Thanks!
        • 1. Re: Movie Clip rollover problem
          Ken_Bruggeman Level 1
          Can anyone offer some help on this?
          • 2. Re: Movie Clip rollover problem
            DLMAES Level 1
            Can you attach your code at least that way I can look at what you're trying to do?

            Also, are you nesting the animated MC inside the Button MC?
            • 3. Re: Movie Clip rollover problem
              Ken_Bruggeman Level 1
              Hi Don,
              Thanks for your response... the only little bit of actionscript that I have is this according to the tutorial:

              tx_mc.onRollOver = function () {
              tx_mc.gotoAndPlay("over");
              }

              and if I am understanding your question properly, yes I am nesting the actual animation in the Btn_MC.... if you pass along your email... I will send the .fla file to you... It SHOULD be working... just cant figure out why it isnt....
              Ken
              • 4. Re: Movie Clip rollover problem
                DLMAES Level 1
                Well because I don't have the file with me, try one of the two options:

                Option 1:

                tx_mc.onRollOver = function () {
                this.gotoAndPlay("over");
                }

                Option 2:

                tx_mc.onRollOver = function () {
                this.tx_mc.gotoAndPlay("over");
                }

                Let me know if this works...
                • 5. Re: Movie Clip rollover problem
                  Ken_Bruggeman Level 1
                  Hey Don,
                  Well i pasted this code into the actions palette in the frame of the main timeline with the button... when I tested it, it didnt work and I got this error code....

                  **Error** Scene=Scene 1, layer=TX Button, frame=1:Line 1: Statement must appear within onClipEvent handler
                  tx_mc.onRollOver = function () {

                  Total ActionScript Errors: 1 Reported Errors: 1
                  • 6. Re: Movie Clip rollover problem
                    DLMAES Level 1
                    It's hard for me to visualize how you set your file up... I just recreated what you've described and it works fine for me. Let me recap and see if I have got this right:

                    1. On your root timeline you have an actions layer.

                    2. On another layer you have a movie clip instance (not a button instance) named tx_mc with an instance name of tx_mc.

                    3. Inside tx_mc movie clip you have an animation that has a label name of "over".

                    If all of this is correct, all you should have to do is in your actions layer write something like the following:

                    tx_mc.onRollOver = function () {
                    this.gotoAndPlay("over");
                    }

                    If it still isn't working I'd have to see your file to see what the problem is...

                    • 7. Re: Movie Clip rollover problem
                      Ken_Bruggeman Level 1
                      WOW! I FINALLY figured it out! Ok this makes me look really stupid, but in case there is anyone else out there that is ever stumped by this same thing... Here you are... My Publish Settings were simply set wrong!!!! I was on ActionScript 1 instead of 2!!! So there you have it! It worked perfectly, it was simply on the wrong publish setting. Hope this helps someone else sometime. Dont thank you for all your input!!!
                      Ken