1 Reply Latest reply on Aug 7, 2009 1:16 PM by adobeforclunkers

    Adobe 9.1.3 and FireFox 3.5.1+ "...can not be used to view PDF files in a Web Browser"

    adobeforclunkers

      This is the issue but I'm not sure there is a resolution:

       

      Firefox:  Version 3.5.1
      Adobe: Version 9.1.3

      When navigating the web, click a URL that opens a PDF inside the browser and you get an error * "The Adobe Acrobat/Reader that is
      running can not be used to view PDF files in a Web Browser
      ".  Please exit Adobe Acrobat/Reader and exit your Web Browser and try again".  I did read a post that doing a "repair" from the Adobe Reader application should fix this, they also reference a few registry keys to check becuase the post states it's lost the application path to Adobe version X.  I don't necessarily buy that "fix" and here are my details below.

      In FireFox if you navigate to Tools > Options > Applications > Adobe Acrobat Document

      You're given choices:

      Always ask:  DOES NOT WORK, produces afore mentioned error *
      Save File:  Works, saves the file to a directory on your PC
      Use Adobe Reader 9.1 (defau...:  Works, opens your PDF's outside of your web browser
      Use Adobe Acrobat (in Firefox):  DOES NOT WORK, produces afore mentioned error *
      Use other...:

      IE seems to just work as expected.

      If you open Adobe Reader > Edit > Preferences > Internet > Check "Display PDF in browser" - DOES NOT WORK, produces afore mentioned error *

       

      This would seem to be an Adobe error rather than a FireFox web browser problems since FireFox does seem to know the correct path although I suppose you can't rule out that this is a FireFox problem since 2 out of the 4 PDF open options DON'T WORK.

       

      Any thoughts on this issue would be greatly appreciated.

       

      Other information:

       

      • Adobe 8.1.5 works perfectly with FF 3.5.1+ when opening PDF's in the web browser, we also had no problems with previous versions either.
      • MSI push via Active Directory from Adobe 8.1.5 upgrade to Licensed Distribution I signed up for, Adobe 9.1.3 which was upgraded from 9.1.0, to 9.1.2, to 9.1.3 via an MSP patch.
      • Operating system:  Windows XP SP 2, plenty of RAM, plenty of Drive
      • IE version this works with the new version of Adobe 9.1.3 is version 7 (7.0.5730.13)
      • Our FireFox MSI's come from Front Motions website and as far as I know we've never had problems with their MSI's, also tried the new release of FF 3.5.2 from their website.

       

      I think that about covers it.  Anyone else experiencing the same problems or have a patch?

        • 1. Re: Adobe 9.1.3 and FireFox 3.5.1+ "...can not be used to view PDF files in a Web Browser"
          adobeforclunkers Level 1

          After troublshooting this for the entire day today the issue seems to be a MIME problem.

           

          If everything is woking perfectly, in Tools > Options > Applications...

           

          You should see 4 or more things related to Adobe like "Adobe Acrobat Forms Document", etc.  If you don't see at least 4 MIME entries either your Adobe installation is hosed or your FF installation is hosed.  I haven't figured out which is causing the issue.

           

          What I did was remaster my patches from my original Adobe 9.1.0 MSI with the two updates via the command line in the directories with the source files.  On the 9.1.0 original file I first remastered my MST transform with the Adobe MST utility.  I then applied my patches.

           

          msiexec /a AcroRead.msi /p AdbeRdrUpd912_all_incr.msp

          msiexec /a AcroRead.msi /p AdbeRdrUpd913_all_incr.msp

           

          I then uploaded that to my network share, unlinked my group policy, made a new group policy, added a batch file to delete adobe.com from program file and the desktop on system startup even though my MST was supposed to take care of that - it's not a perfect world is it?  :-)

           

          I then reapplied my GPO's for both FireFox 3.5.2 and Adobe 9.1.3, I checked to make sure the MIME extensions were there and they were.  You might have to go into your Adobe Preferences and select that open in browser setting depending on what happens or adjust your MIME settings in FireFox's options but it should work.

           

          That's what worked for me.  It's possible a few other things I did along the way tweaked it out, in my group policy on the first run I did select to upgrade previous group policies, for the remaster and repush I didn't select any previous GPO's to upgrade.

           

          It's hard to tell what one thing tweaked it out or what combination of things tweaked out the install.  I did also reinstall Adobe 8.1.5 and FF 3.0.10 before doing all this since our machines currently have that setup, I'm not sure if that affected it either, it's just hard to tell but I don't think it did simply because I had done that several times in troubleshooting this issue.

           

          If anyone else has more specifics that would be great!