3 Replies Latest reply on Aug 6, 2008 5:36 AM by Wesaidso

    Install error FB3 on Leopard

    Wesaidso
      Hi I try to get started using FlexBuilder 3 on Leopard using jdk 1.6.0_05, but I keep on getting an error during installation. I removed all previous installations, run the setup as root, etc, etc. I also installed a fresh eclipse 3.2.2 but this has no effect. I always end up with the error underneath:

      !SESSION 2008-07-31 21:23:48.160 -----------------------------------------------
      eclipse.buildId=unknown
      java.version=1.6.0_05
      java.vendor=Apple Inc.
      BootLoader constants: OS=macosx, ARCH=x86_64, WS=carbon, NL=nl_NL
      Framework arguments: -application org.eclipse.update.core.standaloneUpdate -command install -from file:/Applications/Adobe Flex Builder 3/com.adobe.flexbuilder.update.site/ -featureId com.adobe.flexbuilder.feature.standalone.osx -version 3.0.194161
      Command-line arguments: -application org.eclipse.update.core.standaloneUpdate -command install -from file:/Applications/Adobe Flex Builder 3/com.adobe.flexbuilder.update.site/ -featureId com.adobe.flexbuilder.feature.standalone.osx -version 3.0.194161

      !ENTRY org.eclipse.update.core 4 0 2008-07-31 21:23:54.940
      !MESSAGE Featurecom.adobe.flexbuilder.feature.standalone.osx 3.0.194161cannot be found onfile:/Applications/Adobe Flex Builder 3/com.adobe.flexbuilder.update.site/
      or a newer version is already installed.

      ========
      When I try to start Flexbuilder I get this error:

      !SESSION 2008-07-31 21:25:11.376 -----------------------------------------------
      eclipse.buildId=unknown
      java.version=1.5.0_13
      java.vendor=Apple Inc.
      BootLoader constants: OS=macosx, ARCH=x86, WS=carbon, NL=nl_NL
      Command-line arguments: -os macosx -ws carbon -arch x86

      !ENTRY org.eclipse.equinox.app 2008-07-31 21:25:13.715
      !MESSAGE Product com.adobe.flexbuilder.standalone.product could not be found.

      !ENTRY org.eclipse.osgi 4 0 2008-07-31 21:25:13.729
      !MESSAGE Application error
      !STACK 1
      java.lang.RuntimeException: No application id has been found.
      at org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer. java:236)
      at org.eclipse.equinox.internal.app.EclipseAppContainer.start(EclipseAppContainer.java:98)
      at org.eclipse.equinox.internal.app.Activator.addingService(Activator.java:112)
      at org.osgi.util.tracker.ServiceTracker$Tracked.trackAdding(ServiceTracker.java:1064)
      at org.osgi.util.tracker.ServiceTracker$Tracked.trackInitialServices(ServiceTracker.java:926 )
      at org.osgi.util.tracker.ServiceTracker.open(ServiceTracker.java:330)
      at org.osgi.util.tracker.ServiceTracker.open(ServiceTracker.java:274)
      at org.eclipse.equinox.internal.app.Activator.start(Activator.java:54)
      at org.eclipse.osgi.framework.internal.core.BundleContextImpl$2.run(BundleContextImpl.java:9 99)
      at java.security.AccessController.doPrivileged(Native Method)
      at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextIm pl.java:993)
      at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:9 74)
      at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:346)
      at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:260)
      at org.eclipse.osgi.framework.util.SecureAction.start(SecureAction.java:400)
      at org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter.postFindLocalClass(EclipseLa zyStarter.java:111)
      at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClass(ClasspathManager.java :417)
      at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.findLocalClass(DefaultClassLoade r.java:189)
      at org.eclipse.osgi.framework.internal.core.BundleLoader.findLocalClass(BundleLoader.java:34 0)
      at org.eclipse.osgi.framework.internal.core.SingleSourcePackage.loadClass(SingleSourcePackag e.java:37)
      at org.eclipse.osgi.framework.internal.core.BundleLoader.findClassInternal(BundleLoader.java :405)
      at org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:369)
      at org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:357)
      at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.jav a:83)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
      at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:374)
      at org.eclipse.core.internal.runtime.PlatformActivator.startAppContainer(PlatformActivator.j ava:47)
      at org.eclipse.core.internal.runtime.PlatformActivator.start(PlatformActivator.java:32)
      at org.eclipse.osgi.framework.internal.core.BundleContextImpl$2.run(BundleContextImpl.java:9 99)
      at java.security.AccessController.doPrivileged(Native Method)
      at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextIm pl.java:993)
      at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:9 74)
      at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:346)
      at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:350)
      at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1118)
      at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManage r.java:634)
      at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java :508)
      at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelMana ger.java:282)
      at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManage r.java:468)
      at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:195)
      at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:297)

      !ENTRY org.eclipse.osgi 2 0 2008-07-31 21:25:13.748
      !MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
      !SUBENTRY 1 org.eclipse.osgi 2 0 2008-07-31 21:25:13.748
      !MESSAGE Bundle update@plugins/org.eclipse.datatools.connectivity.oda.template.ui_3.0.4.200706071.jar was not resolved.
      !SUBENTRY 2 org.eclipse.datatools.connectivity.oda.template.ui 2 0 2008-07-31 21:25:13.748
      !MESSAGE Missing required bundle org.eclipse.pde.ui_[3.2.0,4.0.0).

      !ENTRY org.eclipse.osgi 2 0 2008-07-31 21:25:13.749
      !MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
      !SUBENTRY 1 org.eclipse.osgi 2 0 2008-07-31 21:25:13.749
      !MESSAGE Bundle update@plugins/org.eclipse.datatools.connectivity.oda.template.ui_3.0.4.200706071.jar [51] was not resolved.
      !SUBENTRY 2 org.eclipse.datatools.connectivity.oda.template.ui 2 0 2008-07-31 21:25:13.749
      !MESSAGE Missing required bundle org.eclipse.pde.ui_[3.2.0,4.0.0).

      A clue anyone?