5 Replies Latest reply on Aug 15, 2009 12:46 PM by James_PT

    Missing tNG

    James_PT

      I've copied over some DW files to a new site.  However, when I try to access the screens, I get the messag: "Fatal error:  Call to undefined method tNG_multiple::tNG_multiple() in C:\xamp1.7.2\xampp\htdocs\cio\includes\tng\tNG_multipleInsert.class.php on line 42".  I can make a new screen without any problem which will work fine, but the old ones all generate this error.  I've renamed the old Includes file and regenerate a new one but to no avail.

       

      Any ideas on what I am missing?  I copied the entire root directory from onesite into a new site. 

        • 1. Re: Missing tNG
          Albert S. Level 3

          Check the PHP version. ADDT is not compatible with PHP 5.3.0

          • 2. Re: Missing tNG
            James_PT Level 1

            That could be the problem, I was on 5.3.0.  I've reverted back to my original system.  What I would like to do is just upgrade the MySql database to version 5.1.  Is there any easy way to do this?  I've installed the 5.3.1 engine, but the php admin tool ony lets me see the current, old version.

            • 3. Re: Missing tNG
              James_PT Level 1

              I've installed a compete new instance of xampp, 1.7.2 to mySql 5.1 and PHP 3.0.  Unloaded the old database and reloaded the new.  All is working properly - except ADDT.  From an earlier thread, I understand the issue may be incompatibility between ADDT and PHP 5.3.0.

               

              Is there a way to substitute an earlier version of PHP into the xampp directory structure?  What version of PHP is still compatible with ADDT?  I can download an older version of PHP, but not sure which one to use and not sure where it should go.

              • 4. Re: Missing tNG
                Günter Schenk Level 4

                DreamerJim wrote:

                 

                What version of PHP is still compatible with ADDT?  I can download an older version of PHP, but not sure which one to use and not sure where it should go.

                as it´s PHP version 5.3.0 which introduced some significant internal changes which break ADDT, I think that all prior 5.2.x versions should work fine.

                 

                Though I´ve been a die-hard XAMPP user since ages, I´m considering to switch to Wampserver because this one allows you to install multiple PHP (even MySQL and Apache) versions and choose the desired version on-the-fly -- what´s definitely not a bad thing for local development, in particular when developing stuff for multiple customers who (as usual) have their sites hosted on shared hosting servers with varying server configurations.

                 

                Cheers,

                Günter

                • 5. Re: Missing tNG
                  James_PT Level 1

                  Great, thanks so much...

                   

                  I've switched over to Wamp and all is well.