0 Replies Latest reply on Aug 13, 2009 11:35 AM by Paul Reilly

    [svn:fx-trunk] 9273: * This should have been part of revision 9272.

    Paul Reilly

      Revision: 9273

      Author:   preilly@adobe.com

      Date:     2009-08-13 11:35:30 -0700 (Thu, 13 Aug 2009)


      Log Message:


      • This should have been part of revision 9272.


      Code-level description of changes:




          Modified evaluate(Context, ClassDefinitionNode) and

          evaluateInterface() to use ":Object" instead of "Object" when the

          base class is not specified.  This results in a multiname with a

          single namespace instead of one with the package name and all the


      • imports included.  The single namespace multiname should take up

          less space and resolve more quickly.


      Modified Paths: