5 Replies Latest reply on Aug 17, 2009 7:54 AM by Adolfo Rozenfeld

    Motion Blur question

    Victor Burgin

      I'm panning across a view of buildings in downtown Chicago - a lot of "strobing" on all that fine detail (rails on apartment balconies, etc). I apply motion blur and the strobing is much reduced - but it doesn't go away completely. I've tried varying the Shutter Angle, Samples Per Frame Adaptive Sample Limit ... but to no further improvement. Is there anything else can I try? Is there a third-party filter that will help?



        • 1. Re: Motion Blur question
          Navarro Parker Level 3

          Is your AE camera panning across a layer, or is your video camera panning when you filmed it?

          • 2. Re: Motion Blur question
            Victor Burgin Level 1

            I didn't shoot video. I'm panning in AE across a still - so no fields. 

            • 3. Re: Motion Blur question
              Rick Gerard Adobe Community Professional & MVP

              There are certain speeds that must be avoided. A cinematographer worth his day rate knows all about these critical speeds where the movement of the image and the frame rate don't get along. Persistance of vision, stroboscopic effects and frame rate interact to cause these jitters. The only way to fix the problem is to change the speed of the move or the frame rate.


              You can render with fields if your output is video even i the source isn't interlaced. Sometimes this helps, sometimes it doesn't. If you view the comp at about 800% you should be able to tell if the image is moving at a speed that will never work because the edge detail is flickering because the movement isn't in whole pixels. You can only see stroboscopic jitter after you render.


              if I wasn't answering with the touch screen on my iPhone I'd give you a detailed explanation. I've given sevral before. Try a search.


              Edited: Now I'm at a computer I can give you a bit more.


              Vertical movement of vertical edge detail needs to be at even multiples of the frame/field rate when measured in pixels per second. IOW, non interlaced minimum movement is 1 pixel per frame, interlaced movement 2 pixels per field. This rule holds until you're moving fast enough that motion blur hides the edge detail.


              Some have used Math.round expressions to force even pixel increments but this doesn't prevent a skipping problem when the rounding function moves the image 2 pixels instead of 1 or 3 pixels instead of 2 on occasion. You can use this simple expression to do rolls (vertical moves) that will always avoid the sub pixel or out of position flicker. Apply to anchor point or position:

              r = 2 ;  // pixels per frame
              y = value [1] + time / (thisComp.frameDuration/r);
              [value[0], y]

              Horizontal movement isn't as easy to fix. Any good cinematographers handbook will contain a critical panning speed table that matches focal length (angle of view) shutter angle (exposure time) FPS (frames per second) to critical panning speeds in º/second (degrees per second) Because of the way film is projected, because of the rotating shutter in a film camera and the rotating shutter in the projector, retinal retention (the thing that makes it possible for us to interpret a sequence of images as a moving picture) there are panning speeds that produce a weird stroboscopic jittering that's really distracting. This same principal applies to any kind of animation for film, video, or web deployment. The lower the fps the more likely it is that you will encounter this problem. The problem can and does appear even if your horizontal movement is exactly a whole pixel (1 pixel per frame, 1 pixels per frame etc.) because it depends on the frame rate of the movie, the refresh rate of the display, and even the distance you are from the screen.  I can tell you from experience that a horizontal movement for NTSC video of 1, or 2 or 3 pixels per frame will work most of the time, and that a rate of 5 or 7 pixels per frame not work most of the time if the footage is interlaced, but I can't tell you why sometimes 4 pixels per frame only about half the time. I almost always render a short test and look at it on a monitor to make sure.


              If you can't live with this narrow range of speeds then your only other option is to increase the motion blur to hide the annoying flickering details. This isn't an AE bug or glitch, it's a mathematical problem caused by the interaction between frame rates, movement, and the ways our eyes perceive movement. It's the same thing that causes stage coach wheels to appear to turn backwards, or stop, or turn forward as the coach moves across the screen at different speeds.


              I probably didn't solve our problem, but at least you now know a little more about what is causing it.

              1 person found this helpful
              • 4. Re: Motion Blur question
                Victor Burgin Level 1

                Very many thanks for such a comprehensive and insightful response - that's enormously helpful.


                Deadlines allowing no time for working through your suggestions, I just went ahead and rendered the comp with Motion Blur applied. Surprise ! The moiré-like strobing that disfigures the RAM preview completely disappeared. In its place, however, was an occasional hesitation, as if frames were being dropped. I transformed the lossless Animation to H.264 (in Compressor) ... no change. I tried rendering again at 30 fps rather than 24. No change. From what you say, I can only suppose that this phenomenon too is perceptual in nature rather than something that can be fixed in AE.

                • 5. Re: Motion Blur question
                  Adolfo Rozenfeld Adobe Employee

                  Motion Blur won't help with stuttering or strobing. Motion Blur is all about a more natural perception of motion by simulating the behavior of a camera shutter, so that elements appear more blurred the faster they move (as it would happen with a real shutter).

                  Everything Rick said is the key to this problem. If you apply the Reduce interlace flicker effect, in Effects > Blur with a setting of around 1.0 it may help a bit.