9 Replies Latest reply on Aug 24, 2009 2:15 PM by kwp2

    How to get index words to open in a "new window"

    kwp2

      I am using RoboHelp 7, WebHelp.

       

      I want some of my index words to link to www and NOT a topic.  I can do this but when you click on the index word it opens the link in the RoboHelp pane and NOT a new window.  I thought I figured out how to fix this by right-clicking on my index word, choosing Properties, Advanced, and click on the down arrow next to Frame and choose New Window.  I was so proud of myself for figiuring this out.  After I published my site, this still won't open the link in a new window.  Does someone know if this is a known bug or am I doing something wrong?  Thanks for your help.

        • 1. Re: How to get index words to open in a "new window"
          RoboColum(n) Level 5

          It isn't a bug. It is just the way an index works. The index is internal to a help file and is not designed to point to external elements. Could this be better handled by the topics containing the relevant keywords having links to the www page?

           


          Read the RoboColum(n).

          • 2. Re: How to get index words to open in a "new window"
            RoboColum(n) Level 5

            Just reread your post and saw you have got the index keyword to open a URL just not in a new window. Out of curiosity I (and others) would be interested to know how you've achieved this. As far as your question is concerned though, you maybe able to achieve the results you want through the use of a redirect topic.

             


            Read the RoboColum(n).

            • 3. Re: How to get index words to open in a "new window"
              RoboWizard Level 4

              Hi there

               

              I just tested and the settings you mentioned caused my own WebHelp to open the link in a new window (well, it appeared as a new tab in FF, but it worked there). I also tested in IE and it worked in that as well.

               

              Have you tested from different machines? Perhaps it's a configuration setting on your PC?

               

              Cheers... Rick

               

               

              Helpful and Handy Links

              RoboHelp Wish Form/Bug Reporting Form

              Begin learning RoboHelp HTML 7 or 8 within the day - $24.95!

              Adobe Certified RoboHelp HTML Training

              SorcerStone Blog

              RoboHelp eBooks

              • 4. Re: How to get index words to open in a "new window"
                kwp2 Level 1

                Thanks for your answer.

                 

                Sometimes the index word is tied to our internal "Intranet" site where they can find the answer easily.  We do because we don't have to duplicate the information inside RoboHelp using a topic.  If we update the information on the Intranet, then I would have to rememer to update the information in RoboHelp in the topic. To avoid that we have the answer in one place.  So we send our readers to the Intranet to get information on their index word.  Sometimes this index word is tied to a form they can fill out.  We want it to open in a "new window".  I know we can create a topic in RoboHelp and place a link there.  So when a person clicks on the index word it will open up the topic, then they can click on a link here that will open a new window and take them to the page in the Intranet.  But 3 clicks to get to someplace is a little too much.  Don't you think?

                 

                Thanks again for your suggestion.

                • 6. Re: How to get index words to open in a "new window"
                  kwp2 Level 1

                  I had to think outside the box.  It took me a while to figure it out but this is what I did.  I had to figure out a way to get a URL into my "Remote URL" folder.  This is what I did:

                   

                  • Created a FOLDER called URL.
                  • Create a topic called URL and placed it in my URL folder.  Why did I create a folder and a topic both called URL?  Because I did not want my URL topic as part of my Table of Contents.  When I "auto-create" my TOC I can delete this folder real quick at a glance before I publish.  Might not make sense to you but it works for me (smile).
                  • In this URL topic I type my index word and link it to a URL.  Doing this will place the URL in my Remove URL folder.  I repeat this every time I have a new word I want linked to a URL.  In other words this page is full of index words with links (URLs).  (Not all my index words are done this way.  Only those I want to go to a URL).
                  • Now in my index I create my index word and drag the URL into the "Topics For" field (at the bottom of your Index window).  I take it from my Remote URL folder.
                  • After you publish if you click on an index word that is tied to a URL, it will open the URL right there.  Easy.
                  • What I am trying to do is get the URL to open in a "new window" and not the pane in RoboHelp. 
                  • To do this I right click on my index word and choose Properties, Advanced and click the down arrow in the field called "Frame".  I choose "New Window" then click OK.
                  • The only problem is these words still do NOT open in a new window.

                   

                  I've had some suggestions from the users here I will try.  I may just have to create a topic for each index word that's tied to a URL.  When a person clicks on the index word, it will open up the topic, then they will have to click again on the link taking them to the URL.  Too much clicking for me, but maybe that's all I can do for now.

                   

                  I hope this helps.  Thanks.

                  • 7. Re: How to get index words to open in a "new window"
                    RoboWizard Level 4

                    Odd that the same (and simplified) steps on my own PC are failing to produce something usable on yours!

                     

                    The steps you listed certainly seem like more effort!

                     

                    Cheers... Rick

                     

                     

                    Helpful and Handy Links

                    RoboHelp Wish Form/Bug Reporting Form

                    Begin learning RoboHelp HTML 7 or 8 within the day - $24.95!

                    Adobe Certified RoboHelp HTML Training

                    SorcerStone Blog

                    RoboHelp eBooks

                    • 8. Re: How to get index words to open in a "new window"
                      kwp2 Level 1

                      BINGO!!  HALLALUJAH!  IT WORKS! THANK YOU, THANK YOU!!

                       

                      That was it!  I was doing the same thing as you EXCEPT I was dragging my URL from Remove URL folder into the "Topics For" folder.  Then I would right-click on the index word, select properties, advanced, click on the down arrow on the frame field and select "new window".  I did not use the  "New Keyword Topic" in the "Topics For" window to set up my URL.  It was the way I was bringing in my URL that hindered it from opening in a new frame.  Go figure!!

                       

                      Rick, the way you attached the URL to the index word eliminates the need for me to bring in my URL and place it in the Remove URL folder.  I can't thank you enough.

                       

                      Rick, are you the Rick who taught my RoboHelp class in Portland (Beaverton), Oregon in 2008?  If so, I learned so much from you and am still learning.

                       

                      Again, thank you so much!!  I owe you!!

                      • 9. Re: How to get index words to open in a "new window"
                        kwp2 Level 1

                        Rick, I have a "twilight zone" question for you.  Last week you helped me attached a web link to all my index words (keyword and subkeyword).  I tried them and they ALL worked.  I published them and was so happy with the results.  I moved on.

                         

                        A couple of days later  some STOPPED working.  All the keyword indexes work find (open in a new window) but all the subkeyword indexes don't.  After I generate a SSL, I view them in the "View Result".  They ALL work and open in a new window.  After I publish them, only the keywords open in a new window.  The subkeywords do not.  WHAT HAPPEND?  I did not change any settings on my WebHelp.  Why would the view results show them working but after publishing they do not.  Do you have any ideas?  I'm pulling my hair out (smile).