0 Replies Latest reply on Aug 16, 2009 10:16 PM by 2009-08-17

    this application has failed to start because msvcr71.dll was not found

    2009-08-17

      Hi,

       

      I just downloaded the Flex 3.3 DK from here:

      http://www.adobe.com/cfusion/entitlement/index.cfm?e=flex3sdk

       

      Once unzipped I went to run this:

      C:\DATA\My Documents\_jim\flash\open-source\_Software\flex_sdk_3\bin\mxmlc.exe

       

      When I ran it, I got this error

       

      This application has failed to start because msvcr71.dll was not found. Re-installing the application may fix this problem

       

      I searched on Google, and found this:

      http://www.flashdevelop.org/community/viewtopic.php?f=13&t=2932&start=15

       

      So from there, downloaded "msvcr71.dll", placed here:

      C:\WINDOWS\system32

       

      And ran the following in the Command prompt: regsvr32 "msvcr71.dll".

       

      When I did that, I got this error message:

      msvcr71.dll was loaded but the DLLRegisterServer entry point was not found
      The file was not registered

       

      I saw that the DLL is related to Microsoft Visual Basic Runtime, so I deleted the dll I saved manually, and ran the Microsoft Visual C++ 2008 Redistributable Package (x86) from here:

      http://www.microsoft.com/DOWNLOADS/thankyou.aspx?familyId=9b2da534-3e03-4391-8a4d-074b9f2b c1bf&displayLang=en

       

      Once done, the dll was not placed in the System32 folder.

       

      I tried the manual install of the DLL again, but on trying to register it again, got the same error message.

       

      Has anyone else had this problem?

       

      Seems like I might have hit a brick wall.

       

      Thanks