11 Replies Latest reply on Feb 23, 2010 11:00 AM by jspence444

    Premiere Pro CS4 on Mac: Can't play media anymore

    illergeek

      Hi experts,

       

      I'm in huge trouble with my Premiere Pro CS4 (latest version, all updates installed) on the Mac platform:

       

      Until I tried to record an audio track with the built-in microphone, everything worked fine. But since then, Premiere Pro is unsuable . It won't play  any media file (video or audio) anymore: whenever I try to start the playback (no matter what media and no matter in which monitor) Premiere just does nothing at all.

       

      The problem exists since Premiere Pro crashed when I tried to record audio with the built in mic. I can reproduce the crash when ever I try to capture audio again: the error message points to line 2329 in the module "CoreAudioHost.cpp" (to be precise: /Ironside/4.0/MediaCore/MediaLayer/AudioSupport/Macke/Mac/../../Src/Mac/CoreAudioHost.cpp -2329)

       

      I reinstalled the application but the problem still exists. And I checked all the settings in the preferences panel -- but they seem to be alright.

       

      I really have no idea what to do. Hopefully, anybody of you has?

       

      Any help would be gladly appreciated.

       

      Thanks

       

      illergeek

        • 1. Re: Premiere Pro CS4 on Mac: Can't play media anymore
          Jeff Bellune Adobe Community Professional

          Is Soundflower installed on your system?  It has known crashing conflicts with Soundbooth, so those may spill over to Premiere as well.

           

          -Jeff

          • 2. Re: Premiere Pro CS4 on Mac: Can't play media anymore
            the_wine_snob Level 9

            I've not heard of the program that Jeff asked about, but iSight (there are two - one free and one for pay), that uses the Web-cam, whether built-in, or add-on, has been known to cause issues for PrPro. Most were with regards to Capturing from a FW attached camera, but there were others, as well.

             

            Good luck,

             

            Hunt

            • 3. Re: Premiere Pro CS4 on Mac: Can't play media anymore
              illergeek Level 1

              Hi Jeff, Hi Hunt,

               

              thank you for your replies.

               

              The program Jeff talks about (Soundflower) is not installed on my machine, but since I use an 24" iMac, it comes with a built-in iSight camera. However, it didn't cause any problems with Premiere Pro so far. Everything worked well.

               

              When I use the audio and video hardware with other applications (other than Premiere Pro and Soundbooth) eveything still works fine.

               

              What's a little bit strange to me is, that even a reinstallation of the software (Premiere Pro) didn't fix my issues.

              Thanks

               

              illergeek

              • 4. Re: Premiere Pro CS4 on Mac: Can't play media anymore
                Bob Ramage Level 1

                I'm using PPro on my Mac and I don't have the file that is causing you problems. My file structure also looks completely different, with different names for folders. Odd. Are you using any 3rd party plugins?

                • 5. Re: Premiere Pro CS4 on Mac: Can't play media anymore
                  illergeek Level 1

                  Hi Bob,

                   

                  no, it's not a Beta, it's the full version of PPro as it comes bundled within my Master's Collection of CS4. And I'm not using any 3rd party plugins either.

                   

                  I don't think that the file is present on our machines, Bob. The file extension ".cpp" seems to me like a reference to the source code file (written in the programming language C++, since this is what "cpp" stands for). I have a programming background, and therefore I think, the error message isn't meant to be useful for the end user (like us) but for the engineers while they're developing.

                   

                  But today, I could narrow down my problem a bit. The playback is working again: the problems were caused by some messed up audio *output* settings. I think, PPro messed them up when it crashed several times. I reset them all and now the playback works fine again.

                   

                  However, I still can't record: neither with Soundbooth CS4 nor with PPro. The software won't recognize my *input* settings. The error message I gave in my previous post still occurs as soon as I press the little microphone button in PPro's Audio Mixer. And Soundbooth just does *nothing* at all when I try to record. But every other tool (iMovie, Audacity) works fine with my Mac.

                   

                  As a workaround, I record my audio with Audacity, import the file to PPro and be up and running. But if somebody of you has faced similar problems, I would appreciate your solutions.

                   

                  Regards and Thank you

                   

                  illergeek

                  • 6. Re: Premiere Pro CS4 on Mac: Can't play media anymore
                    the_wine_snob Level 9

                    I was about to ask about your Audio Hardware settings, but you beat me to it.

                     

                    Now, as for your mic, my guess would be that there is a mismatch there, as well. Not being a Mac-guy, you probably have ASIO Input & Output settings that will be Greek to me. Still, if you list them, then maybe a Mac-person will recognize a problem.

                     

                    Good luck,

                     

                    Hunt

                    • 7. Re: Premiere Pro CS4 on Mac: Can't play media anymore
                      SteveKer Level 1

                      Just wanted to say that I was having the same issue.  No video playback whatsoever, timecode didn't move although the playback icon showed an arrow not the square.  I altered my Audio Hardware / Output preferences, saved them, then changed them back to what they were in the first place, and everything started working normally (although I haven't attamepted any capturing at all yet).

                      • 8. same problem
                        designerphill

                        i seem to be having a similar problem running PPro in a similar environment except i have imported a file from photoboth and the file will not play in Ppro maybe a split second  i followed the advice about changing hardwear settings and got an error message "/randal/MediaCore/MediaLayer/AudoioSupport/Make/mac/../..Srcmac/CoreAudioHost.cpp-536" same error different line i think any suggestions

                        • 9. Re: same problem
                          lostinthe619 Level 1

                          Hate to bump an old thread, but I'm new to Pr and am also experiencing the same problem and was wondering if anyone had any solutions?

                          • 10. Re: same problem
                            designerphill Level 1

                            i never did find a solution and i did try there is another thread which i started were some more experience then me tried to offer some advice but in the end i just reinstalled the whole creative package as just isolating the problem programmes them being premier and sound booth didn't work i didn't uninstall first just wrote over the top not had the problem since

                             

                            hope this helps still would like to know what it was and why it happened so i can avoid it in future

                             

                            Phill

                            • 11. try here?
                              jspence444 Level 1

                              may I suggest looking in this thread: http://forums.adobe.com/thread/565659?tstart=0

                               

                              There are now a number of us reporting these playback problems, both on Mac and Windows based systems.

                              I posted a screenshot as well as a screen capture of the issues I am experiencing - try checking them to see if you are having the same thing.

                               

                              I feel your frustration.