2 Replies Latest reply on Aug 19, 2009 7:49 AM by Michael Hovey

    Problems with axis labels on ColumnChart

    Michael Hovey Level 1

      For whatever reason, the data displays correctly, but I cannot get any labels to show up on either the vertical or horizontal axis. I feel like I've tried everything, including axisRenderers and labelFunctions but still nothing. Anyways, the actual data is loaded at runtime, but here's the structure for the dataProvider:

       

      [Bindable]
      private var _entries:ArrayCollection = new ArrayCollection([
           {date: new Date(2009, 7, 1), time: 6},
           {date: new Date(2009, 7, 2), time 7.5},
           {date: new Date(2009, 7, 3), time:5},
           {date: new Date(2009, 7, 4), time: 6.6}
      ]);
      
      

       

      And here's the ColumnChart:

       

      <mx:ColumnChart
           id="reportChart"
           left="5" right="5" top="5" bottom="5"
           dataProvider="{this._entries}"
           showDataTips="true"
           dataTipFunction="reportChartDataTipFunction">
           
           <mx:horizontalAxis>
                <mx:DateTimeAxis
                    id="reportChartDateAxis" 
                    dataUnits="days"
                    labelUnits="days"
                    dataInterval="1"
                    displayLocalTime="true" 
                    displayName="Date"/>     
           </mx:horizontalAxis>
           
      
      
           <mx:series>
                <mx:ColumnSeries
                     xField="date"
                     yField="time"
                     labelField="time" />
           </mx:series>
           
      </mx:ColumnChart>
      

       

      Any help would be greatly appreciated!