1 Reply Latest reply on Aug 19, 2009 8:19 AM by adamheinz

    "Error launching the test runner." running FlexUnit tests from CruiseControl

    adamheinz

      Looking for suggestions on what to try next running down a problem that manifests ONLY when I run FlexUnit (SDK 3.2.0.3794) tests from CruiseControl on RHEL4.  These same tests run from the command line without error.  I've already googled my error message, turning up only the following suggestion that the standalone flashplayer is not installed.

       

      $ rpm -q --whatprovides /usr/share/flash-standalone-player/bin/flashplayer
      flash-standalone-player-9.0.115.0

       

      (Google cache)

      http://74.125.95.132/search?q=cache:GYEBG7gubUIJ:blogs.adobe.com/pmartin/archives/2006/06/ new_flexunit_an.html+flexunit+ant+task&cd=1&hl=en&ct=clnk&gl=us&client=firefox-a

       

      If I tail the ant build log, I see that it terminates with

       

      [flexunit] opened server socket

      BUILD FAILED
      /opt/cruisecontrol/checkout/studio/build.xml:552: The following error occurred while executing this line:
      /opt/cruisecontrol/checkout/studio/build.xml:536: Error launching the test runner.

       

      If I run the tests from the command line, they succeed.

       

      [flexunit] opened server socket
      [flexunit] accepting data from client

      ...

      [flexunit] end of test run

      BUILD SUCCESSFUL

       

      This suggests that there is a network disconnect.  It does look like the listener is grabbing its port without issue.

       

      $ sudo netstat -nap | grep 1024
      tcp        0      0 :::1024                     :::*                        LISTEN      31868/java

       

      So that's as far as I've tracked this problem.  I'm looking through FlexUnitTask.java right now and will add some debug statements to it if I get some time today.  I'm thinking there may be a race condition in that the thread that is created to listen to test results has not finished setting up before the flashplayer runs the tests.  Going to look into the FlexUnit code as well to see if the test polls the listening port a few times or gives up if the initial request fails.

       

      Whew!  All that said, any other ideas for stuff to look at?