0 Replies Latest reply on Aug 20, 2009 7:43 PM by darndt2

    Word breaks incorrect when wrapping Greek text

    darndt2

      Hi,

       

      I'm trying to use Greek in Illustrator, but I'm getting line breaks in the middle of words. This sort of problem also applies to other languages. Does anyone know how this problem might be resolved?

       

      Note that this is NOT the same thing as turning off hyphenation; I've tried that and it doesn't work. I'm getting breaks in words without hyphens appearing. I've tried with two sorts of Greek fonts: (1) with the Helena font, which replaces Latin glyphs with Greek glyphs, and (2) with a Greek characters in Unicode with a Unicode-compatible Greek font (SBL Greek). With the first option, it seems that Illustrator is causing breaks where it sees non-alphanumeric characters. With the second option, I'm not sure what the problem is; it's breaking in various strange places.

       

      Setting the language to "Greek" in the Character Pallette does not help. (I'm using ancient Greek, and I'm not sure how that might differ from modern Greek).

       

      Greek_line_wrapping_Helena.png

      Greek_line_wrapping_Unicode.png

       

      The same problem has apparently occurred in InDesign, and there is even a solution or two in InDesign (see the 2nd link) involving either setting the language to "No Language" (cannot be done in Illustrator, as far as I can see), or find and replace character styles (again, it seems Illustrator can't do this).

       

      http://forums.adobe.com/message/1873967#1873967

      http://forums.adobe.com/message/1327153#1327153

       

      How might this problem be solved? Setting "No Break" in the Character Pallette for all the words would require tedious selection. Its seems that this problem could be solved by allowing "No Language" to be selected, or by adding an option to only break at spaces. TextEdit on Mac OS X does the latter and wraps the text properly.

       

      Thanks,

       

      David Arndt