7 Replies Latest reply on Aug 30, 2009 1:24 PM by cesaregb

    Error #1009....

    cesaregb Level 1

      Hi all,

       

       

      I'm making a simple and small app, but i keep getting this error:

       

      TypeError: Error #1009: Cannot access a property or method of a null object reference.
          at myTest$cinit()
          at global$init()[/Users/cesargonzalez/Documents/Flex Builder 3/Proveedores/src/myTest.mxml:4]
          at _myTestWatcherSetupUtil$/init()
          at mx.managers::SystemManager/http://www.adobe.com/2006/flex/mx/internal::docFrameHandler()[C:\autobuild\3.2.0\framework s\projects\framework\src\mx\managers\SystemManager.as:3058]
          at mx.managers::SystemManager/docFrameListener()[C:\autobuild\3.2.0\frameworks\projects\fram ework\src\mx\managers\SystemManager.as:2916]

       

       

      my form is quit big that's why i'm not adding it to here, the problem is that i use the exactly same form in other app... and don't give me any errors in the other..

       

      so anyone can tell me why this may be happening .. ?

       

       

      Well.... i hope someone can help me...

       

       

      Regards

      Cesar

        • 1. Re: Error #1009....
          Madhav Subedi Level 4

          post the init function ( or the code piece which is generating the error, by looking at the line ).

          • 2. Re: Error #1009....
            cesaregb Level 1

            Hi,

             

            here is the init function that i'm calling... i fell that is not the problem or may be ...

             


            private function initApp():void {
                var Obj:Object = new Object();
                Obj.bring = "cedula";
                Security.allowDomain(_strDomain);
                ProveedoresDyn.addEventListener(ResultEvent.RESULT, bringCedula);
                ProveedoresDyn.url = _strDomain + "/bringSessions.php"
                ProveedoresDyn.send(Obj);
            }

             

            so i try to delete everything just letting the application tags... and it runs fine, as well i'd delet all the components one each time... but is not working i can't find which one is giving me problems....

             

             

            well.... i hope someone can help me, anyway i'll keep trouble shooting this app that is driving me crazy....

             

             

             

            Thanks... and regards Cesar.

            • 3. Re: Error #1009....
              cesaregb Level 1

              Hi,

               

              In fact i'm not calling the init functino, i don't know where and what component is calling that function cuz the application tag is the only component that call the creationComplete is the application and any other so should be one component...

               


              thanks in advice

               

              Cesar Glez.

              • 4. Re: Error #1009....
                sri harsha namala Level 2

                Hi,

                       The problem is not with your code, Its a Bug upgrade to 3.3 or Try with Different Flash Player i too faced this problem

                1 person found this helpful
                • 5. Re: Error #1009....
                  cesaregb Level 1

                   

                   

                  I upgrade it to the 3.4 and still not working ...

                   

                  anyway thanks for the advice.

                  • 6. Re: Error #1009....
                    Michael Borbor Level 4

                    Most likely you're trying to set a property that hasn't been created yet,

                    debug your app and find out which line of code throws that error.

                    1 person found this helpful
                    • 7. Re: Error #1009....
                      cesaregb Level 1

                      Hi all,

                       

                      I've solved ... it was that i was making reference to the Application.application...  object and that variable didn't exist.. so that was the problem the debuger never told me that it was the problem ... that's why i took so long...

                       

                       

                      well is any have a similar problem check if you r making reference to this..

                       

                       

                      Thanks a lot for your help

                       

                      Regards

                      Cesar