7 Replies Latest reply on Sep 2, 2009 2:45 PM by Neets_NZ

    Inserted SWF file in Presenter uploaded to Connect Pro misbehaves

    Neets_NZ Level 1

      Hi

       

      I have five inserted SWF files in my Presenter file.  Four are demonstrations, the fifth is a training simulation with right-click click box.

       

      I know you need to zip up the training simulation (tested this with the Captivate project) and upload the zip file in order for the right-click to work.  So I figured now this Captivate project is inserted into Presenter I would need to zip up the Presenter file and upload to Connect Pro.

       

      All good so far.

       

      However when I access the URL all my inserted SWF files are messed up.

       

      Some I see the first slide of my CP4 project and it jumps me to the last slide of the project.  Another of the inserted SWF files I hear the audio from the first slide of the CP4 inserted project and it jumps me part way through the project.

       

      Another jumps me to the first quiz slide in the CP4 inserted project.

       

      And my training simulation dumps me part way through it (the right click click box is on one of the earlier slides).

       

      I'm a new user and I can't for the life of me understand this behaviour.

       

      I've been publishing Presenter to My Computer and viewing it in the browser and it behaves as expected, but my training simulation of course wont show the right click.  I knew I'd only get to review this by publishing to Connect Pro.  But now I've encountered a monster.

       

      Sorry for the long-winded explanation.

       

      Can someone help?

       

      thanks
      Anita

        • 1. Re: Inserted SWF file in Presenter uploaded to Connect Pro misbehaves
          leo_leo Level 2

          Hi ,

           

           

          Do you see problems with all CP4 Swf or Cp4 training SWF only .CAn you please provide details ?

          Did you set these SWFs to be managed by Presenter playbar via MAnage SWF window ?

           

           

          -Leo

          • 2. Re: Inserted SWF file in Presenter uploaded to Connect Pro misbehaves
            Neets_NZ Level 1

            i Leo

             

            thanks for replying.

             

            The file plays perfectly in CP4 and perfectly when I publish the Presenter file to My Computer (other than my Training simulation with a right-click click box - but that's the limitation.  You must zip the file and add to Connect Pro for the R/C click box to work).

             

            It's only when I publish the Presenter file to Connect Pro that the problems start.

             

            I don't have Presenter controlling the playbar.  I've got click boxes in my inserted SWF file.  If I have Presenter controlling the playbar then it ignores all the click boxes in the inserted SWF file  e.g. there's a Continue button in the SWF.  If Presenter controls the playbar the user doesn't get to click the button to determine when the SWF file continues to play.

             

            I tested allowing Presenter to control the playbar and it will now play the SWF from start to end, but it just runs along ignoring all the click boxes in the SWF file which means slides progress automatically and no response from the learner is required.  And I need the continue buttons as there's content on some slides that need to be read, and the pace of reading will differ from person to person.  I've also got branching in the SWF which is controlled by the learner pressing either Continue or Quiz type buttons.

             

            I can't put the quiz in Presenter because it wont allow you to publish the Presenter file when there are slides between quiz slides.

             

            So a SWF has the demo and quiz questions.  Then Presnter there's an intro slide to the next SWF.  The SWF with the deom and Quiz.

             

            If I add the quiz questions to Presenter it looks like thisl

            Intro (Presenter slide)

            SWF (instered into Presenter

            Quiz (Presenter sldies)

            Intro (Presenter slide)

            SWF (instered into Presenter

            Quiz (Presenter sldies)  - and so on

             

            So I've got slides between the quizes and Presenter refuses to publish.

             

            Becuase I'm new I'm wondering if I should have tackled this in a different way.

             

            However this demo is for prospects as well as clients.  I wanted Marketing to be able to provide a URL where the recipient doesn't need to log into ACPro to view.

             

            With adding the training simulation I've made it difficult becuase there's a right-click click box so there's limitations as to how I can publish that to Connect Pro.

             

            None of the quiz or training simulation is being reported back to the LMS.  The quiz and training are optional and can be bypassed by using buttons inside the SWF file (branching).

             

            I've managed to get myself into a right pickle ;-)

             

            Thanks

            Anita

            • 3. Re: Inserted SWF file in Presenter uploaded to Connect Pro misbehaves
              leo_leo Level 2

              Hi Anita ,

               

              Thanks for the explaination .

               

              Presenter does allow inserting content slide between Quiz slide .Though it is not allowed for Questions which are part of Question Group to have Content slide in between them .So , you can try Quiz rather than Question Group if that can serve your need . As far as reporting is concerned i am not sure if  Captipate SWF inserted inside Presenter content supports it .

               

              -Leo

              • 4. Re: Inserted SWF file in Presenter uploaded to Connect Pro misbehaves
                Neets_NZ Level 1

                Hi Leo

                 

                thanks for the reply.

                 

                You may have misunderstood my poor explanation.  I don't expect the quiz or training simulation to report back to the LMS.  The quiz and training is optional.

                 

                What we've done is removed my first slide from the training simulation to by pass the right click click which wont work (unless you zip the file and upload to Connect Pro) and instead have put the video directly onto our own website (in our test environment).

                 

                It works just fine.

                 

                So the question still remains why the same file wont play via Connect Pro generated URL.  The video viewed via Connect Pro jumps all around the inserted SWF files.  I can't remember our URL to the hosted Connect Pro.  When I'm at work on Monday I'll update this post with the URL in case you're interested in seeing our predicament yourself.

                 

                I guess we have a work around, but it's not what we wanted.  Though from an end user point of view their experience isn't any different than if they accessed the video via a link connected to Connect Pro.

                 

                Cheers

                Anita

                • 5. Re: Inserted SWF file in Presenter uploaded to Connect Pro misbehaves
                  Neets_NZ Level 1

                  Hi again

                   

                  I remembered the URL to get to our hosted Connect Pro.

                   

                  This is the URL for the demonstration published from Presenter:

                  http://payglobal.na4.acrobat.com/p98747382/

                   

                  Cheers

                  Anita

                  • 6. Re: Inserted SWF file in Presenter uploaded to Connect Pro misbehaves
                    leo_leo Level 2

                    Hi Anita,

                     

                    There is something we can try and i think this can help us .For this, we need Captivate project file and please make sure to take its back up .

                     

                    * open the captivate project
                    * open Project->Advanced interactions
                    * Switch off Add-to-total, Track score and Report answer check boxes in each row.

                    * Publish the project

                     

                    Insert this SWF and see if it works and update me too .

                     

                    -Thanks

                    Leo

                    • 7. Re: Inserted SWF file in Presenter uploaded to Connect Pro misbehaves
                      Neets_NZ Level 1

                      Hi Leo

                       

                      Thanks for your assistance.  I think your reply was to overcome the inability to add quiz slides in Presnter with non-quiz slides between.

                       

                      I had posted my question on the Connect Users forum also.  Someone there was able to play the Presenter file correctly from the URL I posted.

                       

                      Based on that, I had other people inside my company try the URL also and they had no problem.  I then cleared my cookies (as did another person involved with the intial testing) and we've had success.

                       

                      A bit embarrassing really.

                       

                      So thank you, but clearing the cookies has resolved my problem of playing the Presenter file via the Uploaded content in Connect Pro.

                       

                      Cheers

                      Anita