1 Reply Latest reply on Oct 9, 2009 1:46 AM by MicCheckOne

    ACSM file doesn't seem to open (Mac OS 10.5.6) in DE

    nichele_mcclendon

      I downloaded a book and the .acsm file appeared on my desktop, but when I open it using DE, nothing seems to happen. It also seems like nothing happens when I drag the acsm file into the DE window. When I close DE and open it using DE, I get a message from DE saying "One or more downloads are not finished. Do you want to resume pending tasks?" When I click "OK," there is no indication that any download is taking place. Is there a way for me to see pending downloads in DE or another way to avoid this problem and get access to my e-book? Thanks in advance for any/all help!

        • 1. Re: ACSM file doesn't seem to open (Mac OS 10.5.6) in DE
          MicCheckOne

          Here's what I did.  I had the same problem when I tried to download an e-book I purchased.  I was using the Safari web browser, and when I clicked on my download link, it would just download the .acsm file to my computer's Downloads folder, not load the book into Digital Editions.  When I double-clicked on the .acsm file and told it to "Open with Adobe Digital Editions," it wouldn't do anything, either.  The solution that worked for me was to use the Firefox web browser instead.  In Firefox, when I clicked on my download link, it brought up a window that asked if I wanted to Open the file or Save it to my computer.  I chose "Open" and then chose "Other" from the application list, navigated to Adobe Digital Editions, and finally the download began inside Digital Editions.  What a hassle, but it worked.