9 Replies Latest reply on Sep 1, 2009 7:00 PM by D. Fraser-1eqWmH

    Proper Illustrator version for my Mac?

    JimSned Level 1

      My Mac has system 10.5.7.   Should Illustrator version 10.0.3 be able to work properly on it?   It doesn't seem to want to.  Any ideas why it doesn't work?

       

      If not, what version do I need?  Can I get a free upgrade somewhere?

       

      Thanks for your help.