6 Replies Latest reply on Nov 6, 2009 7:35 AM by armyCoder

    No IIS showing in ColdfusionServer Settings

    jeffcg2 Level 1

      I installed one time with the built in CF Server on port 8501 added CF Builder to Flash Builder 4. Now I am trying setting up just CF Builder on a different machine without Flash Builder 4 using IIS as the local server.

       

      I add the local IIS and remote IIS servers in the RDS panel but when I try to add these into a project they do not show up as option in the ColdFusion Server Settings panel. If I try to "Add Server" I get an error that the server already exists.

       

      I haven't found instructs for setting this up for IIS yet. What needs to be done for IIS?

        • 1. Re: No IIS showing in ColdfusionServer Settings
          jeffcg2 Level 1

          I think this is because IIS is not supported as yet.

          Is that correct?

          • 2. Re: No IIS showing in ColdfusionServer Settings
            Bhakti Pingale Level 2

            IIS is supported in ColdFusion Builder.

             

            You have added the server in RDS and if you have to associate these servers to your project they should be a part of the server manager.

             

            You will have to import these RDS servers into the server manager as explained here: http://blogs.adobe.com/cfbuilder/2009/08/importing_rds_server.html

             

            Then once the server is added you can associate them with your project.

             

            -Bhakti

            • 3. Re: No IIS showing in ColdfusionServer Settings
              jeffcg2 Level 1

              Thank you for the response. It is good to know it is supposed to work.

               

              I keep getting and error message "Invalid Server Home Directory" unless I chose

              c:\Coldfusion9.  Which is NOT the server home on IIS.

               

              So I assume there is something that needs to be configured on IIS before CF Builder will recognize it.

               

              Are you sure this is supposed to work?? ;o)

               

              I did read something about only supporting Jrun. Which is the only way I have been able to get it to work.

              • 4. Re: No IIS showing in ColdfusionServer Settings
                Bhakti Pingale Level 2

                The Server Home is the ColdFusion Server Home. The location where ColdFusion Server is attached. Since Server Manager in CFBuilder adds a ColdFusion server you need to specify the ColdFusion Server Home which I guess in your case is 'C:\Coldfusion9'

                 

                Are you trying to configure multiple sites/virtual hosts in ColdFusion Builder?

                • 5. Re: No IIS showing in ColdfusionServer Settings
                  jeffcg2 Level 1

                  Bhakti,

                   

                  http://blogs.adobe.com/cfbuilder/2009/07/remote_server_setup_-_multiser.html

                   

                  I found this blog today.I followed these instructions and still NO JOY.

                   

                  I still don't see that this is explaining anything but how to get the admin running on a standalone Jrun server. Does this mean that both a standalone Jrun Coldfusion server for the admin and IIS need to be running on the remote machine?

                   

                  I really only care about running this with a single instance of IIS with CF9 at this point. I have the stand alone Jrun server running on my laptop and everything setup up just fine.

                   

                  [localhost], (09/04 at 09:57:08): Server is available. Getting server settings from Server

                   

                  I have yet to try installing the Standalone server on the remote machine along with the IIS to see if this will work. But that seems like it should be unnecessary.

                   

                  I am stuck at this point.

                   

                  [remoteserver], (09/04 at 07:46:55): Server is available. Getting server settings from Server

                  [remoteserver], Error, 09/04 at 07:52:31, The connection to the remote JNDI server on host xxx.xxx.xxx.xxx at port 2910 has failed (as have all backup hosts listed, if any) - please verify that the server is running and the NamingService is available

                   

                  It helped reading the blog in that now when I run the adminstart.bat file it doesn't just flash on the screen and disappear.

                   

                  Now I can see this message. C:\ColdFusion9\AdminServerComponents\runtime\bin>adminstart.bat

                  'jrun' is not recognized as an internal or eternal command, operable program or batch file.

                   

                  I'm guessing that means the bat file was written for a Jrun server??

                   

                  ---------------------------------

                  # JRun security properties can be controlled at the global or server level by
                  # this file.
                  # {jrun.root}/lib - global properties inherited by all servers on the same machine.
                  #   (Installed by default, current subnet only default)
                  # {jrun.root}/servers/{server.name}/SERVER-INF - per server restrictions
                  #   (user must configure this manually)
                  #
                  # security.properties parameters
                  # jrun.subnet.restriction - subnet mask for allowed access
                  #       default - 255.255.255.0 - current subnet only
                  #
                  # jrun.trusted.hosts - comma separated list of trusted hosts or IP addresses
                  #       default - blank (subnet restriction applies)
                  # values
                  # -- Missing or blank entry for either property will exclude it from consideration.
                  # -- * in EITHER property means no restrictions (essentially and 'OR' condition)
                  #   * is NOT recommended for production use.

                   

                  # default configuration - current subnet only
                  #jrun.subnet.restriction=255.255.255.0
                  #jrun.trusted.hosts=

                   

                  jrun.subnet.restriction=*
                  jrun.trusted.hosts=*

                  -----------------------------------

                  • 6. Re: No IIS showing in ColdfusionServer Settings
                    armyCoder

                    FYI, make sure anonymous access is turned on for your root website in IIS. If you need IWA, set it on the subfolders you need. Just got my IIS server working in CFbuilder (finally)