13 Replies Latest reply on Sep 19, 2009 7:48 PM by jdesko

    Flash Builder and Flex4 SDK 9731+ issue

    MikisM87 Level 1

      Hello everyone. I've been working with Flash Builder Beta and latest Flex4 SDK nightly builds for some time now and did not have any major obsticles.

      That was until I downloaded 9731 build. Flash Builder compiled my project without any problem, however, when I tried to launch the application in my browser I've got these errors:

       

      VerifyError: Error #1014: Class IVisualElement could not be found.

       

      (after I click continue)

      ReferenceError: Error #1065: Variable CrossFade_CrossFadeShaderClass is not defined.

       

      (after that)

      ReferenceError: Error #1065: Variable Wipe_WipeShaderClass is not defined.

       

      (and after that)

      ReferenceError: Error #1065: Variable _cfdd017153b35cc39170086d5b82e02ae917ac7c68abee5c5b64ce1a052a4aac_flash_display_Sprite is not defined.

       

      Of course when I click "Continue" nothing shows up on the screen.

       

      The only similar issue I've managed to find is related with Flexmojos (http://code.google.com/p/flex-mojos/issues/detail?id=163) which, I think, has nothing to do neither with Flex4 SDK nor Flash Builder in this case.

       

      Maybe anyone has ideas about this? Does this have something to do with Flash Builder incompatibility with nightly SDK builds? Or maybe the new SDK

      has not been built correctly?

       

      By the way, I've decided to stick with 9674 built and wait for more nightly builds when I first encautered this problem. Today I've downloaded 10008 built of

      Flex4 SDK and the problem is still there.

        • 1. Re: Flash Builder and Flex4 SDK 9731+ issue
          jdesko Level 2

          FWIW; I had the same problem with SDK 9731, so I went back to 9437, but then with that SDK I was getting a #2032 error with a frameworks swf (sorry switched SDK's and don't remember exact error at this time).  Today I am trying the latest nightly 4.0.0.10034 and am getting

          <Could not resolve <s:SimpleText> to a component implementation> so if anybody has any ideas?

          • 2. Re: Flash Builder and Flex4 SDK 9731+ issue
            jdesko Level 2

            To follow up with my last post (FWIW) with SDK 4.0.0.10034 <could not resolve <s:SimpleText> ...> is my only error before running the app, no IVisualElement errors with this SDK.  So I have to resolve the SimpleText error or use something else before running the app to check for other errors.

            • 3. Re: Flash Builder and Flex4 SDK 9731+ issue
              jdesko Level 2

              To follow up again with the latest nightly build 4.0.0.10034 - they replaced Sparks:SimpleText(no more) with Sparks:Label.  But when running the app I get the IVisualElement problem:

               

              Main Thread (Suspended: VerifyError: Error #1014: Class IVisualElement could not be found.)

              • 4. Re: Flash Builder and Flex4 SDK 9731+ issue
                jdesko Level 2

                I resolved the issue with IVisualElement (sorry for all of the posts).

                 

                In the Project properties / Flex Build Path / Library Path / under the SDK I moved framework.swc up to the top of the .swc list (I don't know if the top or first in the list was necessary).  I did this while using SDK 4.0.0.10034.

                 

                However, when I run my app I am getting this error (but the app runs):

                 

                Error #2032: Stream Error. URL: http://localhost/bin-debug/framework_4.0.0.10034.swf

                Failed to load RSL framework_4.0.0.10034.swf

                Failing over to RSL http://fpdownload.adobe.com/pub/swz/flex/4.0.0.10034/framework_4.0.0.10034.swf

                Warning: Ignoring 'secure' attribute in policy file from http://fpdownload.adobe.com/pub/swz/crossdomain.xml.  The 'secure' attribute is only permitted in HTTPS and socket policy files.  See http://www.adobe.com/go/strict_policy_files for details.

                • 5. Re: Flash Builder and Flex4 SDK 9731+ issue
                  MikisM87 Level 1

                  Thank you very much. Moving framework.swc to the top of all other Flex4 libraries resolved the IVisualElement issue.

                  However I am unable to reproduce the Stream Error you have encountered. It would seem that framework_4.0.0.10034.swf file is not in the bin-debug folder and flash player downloads it from the http://fpdownload.adobe.com/pub/swz/flex/4.0.0.10034/. I think you should see if the file is present in bin-debug folder when you build your app with Flash Builder just to make sure. I hope you will find a solution to your problem.

                  • 6. Re: Flash Builder and Flex4 SDK 9731+ issue
                    jdesko Level 2

                    Thank you very much in return. After you pointed that out I noticed that in my project's build path library for SDK 4.0.0.10034 that the RSL URL for both framework.swc and rpc.swc was pointing to 4.0.0.9779 even though the source attachments were pointing to 4.0.0.10034.

                    • 7. Re: Flash Builder and Flex4 SDK 9731+ issue
                      ThinkLOOP Level 1

                      Guys thank you so much for posting, you helped me out a lot. I experienced the same issues using 4.0.0.10339

                       

                      One additional issue with this new build is that flex LIBRARY projects now produce the error:

                       

                      "component RichText is defined more than once in this namespace.  Remove the mapping to spark.components:RichText or spark.primitives:RichText"

                       

                      Not sure what to do about that.

                      • 8. Re: Flash Builder and Flex4 SDK 9731+ issue
                        jdesko Level 2

                        Right now I'm trying to figure out why updating the SDK to 10339 why my last used SDK version is showing under bin-debug (as shown below); I've restarted FB and cleaned several times (FWIW).  This has been a recurring problem when installing a new SDK.  I do not have this problem with a new project, just existing. The last used SDK .10212 is not referenced under FB's installed Flex SDK's and I moved the folder to a diff. location.

                         

                        My resolution to this problem is to delete the old project (not the files), then create a new project, then move framework.swc in the library path, remove the wrong .swf version files from under bin-debug, and attach all of my modules to the new project in project properties.

                        Picture 2.png

                        • 9. Re: Flash Builder and Flex4 SDK 9731+ issue
                          jdesko Level 2

                          Hello ThinkLoop;

                           

                          I have .10339 now working with no new issues.  If this helps I started a discussion (below) in which I was getting an error, the error given seemed unrelated to the fix but... essentially when recreating the project, which seems to be a common event when updating the SDK, I have to re-attach the modules to the project.

                           

                          AuthorSubjectViewsRepliesLast Post
                          jdeskojdeskoNightly SDK and Flash Builder Betain Flash Builder and Flex SDK121835 minutes agoby jdesko

                          • 10. Re: Flash Builder and Flex4 SDK 9731+ issue
                            Baz (thinkLOOP) Level 1

                            I seem to have 10339 working too, and I also had to re-create the project. When upgrading SDKs, I usually expect to clean 5-6 times, restart eclipse 2-3 times and re-create projects every 2 or 3 upgrades. But I found a trick that's been helping out a lot. Instead of changing the SDK that your projects are pointing to in Flash Builder (causing those "internal build" errors), I made one folder called FlexSDKLive. To upgrade SDKs, you simply copy the new files into that folder. For good measure I close Flash Builder before beginning to copy. It has worked well for 1 out 1 upgrades. A bonus is that I don't have to re-implement different hacks I have in place like re-copying netmon.swc from the original sdk to the current one.

                            On a side-note, I have been working strictly in Flex 4 for several months now, and just recently I had to do something in Flex 3 - it was horrible! I can't believe we survived without being able to make shapes easily, and fills and gradients, and proper skinning. Flex 4 is light years ahead of 3, and it even compiles many times faster!. The team is doing an amazing job. I hope I never have to work in Flex 3 again

                            Baz

                            • 11. Re: Flash Builder and Flex4 SDK 9731+ issue
                              MikisM87 Level 1

                              About that project recreation. I think you guys are doing it too difficult. I solve this problem in a simpler matter, I think. Problem lies in the .actionScriptProperties file. More precisely its the <modifiedEntries/> tag that causes all the trouble. The thing is that for each new release of the SDK it differs slightly so every time I move to a new nightly built, I create a new project, and replace <modifiedEntries/> tag in my old project with the one I find in the project that I've just created. And one more thig I have to do is move framework.swc file to the top of my library path so that it would be above sparc.swc. Of course I make a copy of my original .actionScriptProperties in case something goes wrong. And at last I have to rebuild the project (Project->Clean).

                              Hope this will help you easing things at least a little bit. Cheers!

                              • 12. Re: Flash Builder and Flex4 SDK 9731+ issue
                                jdesko Level 2

                                Mikis;

                                Thanks for the information, I will definitely try next time.

                                John

                                • 13. Re: Flash Builder and Flex4 SDK 9731+ issue
                                  jdesko Level 2

                                  Mikis;

                                   

                                  Your .actionScriptProperties tip worked, thanks.  I always rename my SDK filename to the build #, so in .actionScriptProperties I did a find/replace all on the old SDK# to the New# (didn't have to build a new project and copy <modifiedEntries>).

                                   

                                  John