9 Replies Latest reply on Sep 9, 2009 11:45 AM by tommoon

    Preloader

    tommoon

      Hey guys,

       

      This may seem like a dumb rookie question, but here it goes anyways.

      I have a large captivate file with about 70 slides, 50 of which are videos.  I wanted to get a preloader at the beginning and possibly before the videos if necessary.  I'm having trouble trying to add a preloader.  I tried making my own and had troubles getting it to work, so I decided to use one of the generic ones for now until I get it figured out.  I went into edit > preferences > Start and End and checked the Preloader box and chose one of the default preloaders.  As far as I can tell that's all I need to do.  When I go to preview it however it doesn't show up.  I'm sure I'm doing something wrong but I don't know what it is, please help.

      Thanks

        • 1. Re: Preloader
          RoboWizard Level 4

          Hi there

           

          The problem is that videos load when they are needed and there isn't a way I'm aware of to preload them.

           

          Cheers... Rick

           

           

          Helpful and Handy Links

          Captivate Wish Form/Bug Reporting Form

          Adobe Certified Captivate Training

          SorcerStone Blog

          Captivate eBooks

          • 2. Re: Preloader
            tommoon Level 1

            When I play the module it starts out really choppy, would a preloader at the beginning help that?  Also, could I somehow individually bring the videos into flash and add a preloader there?  I really just need to do something that will make this thing play smoothly

            • 3. Re: Preloader
              tommoon Level 1

              When I use the preloader, I get this error message:

               

                   Adobe Flash Player has stopped a potentially unsafe operation.

                  

                   The following Local application on your computer or network:


                        C:\DOCUME~1\steveu\LOCALS~1\Temp\cp4Temp\~CaA5D7\capA&D1_skin.swf


                   is trying to communicate with this Internet-enabled location:


                        C:\DOCUME~1\steveu\LOCALS~1\Temp\cp4Temp\~CaA5D7\capA&D1.htm



                   To let this application communicate with the Internet, click Settings.

                   You must restart the application after changing your settings.

               

              I went in and changed the settings, the error went away, but I still have no preloader

              • 4. Re: Preloader
                www.cpguru.com Level 4

                Are you using Audio or Question pools in your project?

                 

                /Michael

                 


                Click here to visit my captivate blog.

                • 5. Re: Preloader
                  tommoon Level 1

                  no question pools, but I do have a bit of video with audio in it, and one slide has a stand alone audio clip that's less than ten seconds long.

                   

                  I tried another way of doing this using variables & actions, but wasn't successful in that way either.  I have another post on that subject here:

                  http://forums.adobe.com/thread/476500?tstart=0

                   

                  Any help you guys can give me is greatly appreciated

                  • 6. Re: Preloader
                    www.cpguru.com Level 4

                    Well if you only have 10 seconds audio in your project that can't be the issue.

                     

                    You write "When I go to preview it however it doesn't show up". What do you mean by preview? Are you previewing it from Captivate? If so then it won't work. Your preloader will only show up in your published project. You should set the download percentage for the preloader to 100% in order to have the whole project (ex. videos) load first.

                     

                    Is it the videos that are choppy or the Captivate slides? If it's the videos then it's most likely due to their size and that they are to big. In that case you need to adjust the quality of them using Adobe Media Encoder to reach an acceptable compromise between size and quality.

                     

                    /Michael

                    1 person found this helpful
                    • 7. Re: Preloader
                      tommoon Level 1

                      I preview it in my browser, but it doesn't look like it loads at all.

                       

                      I think you are right on the size of the videos, I've been working on those.  I was just hoping a preloader would help a bit as well.

                      • 8. Re: Preloader
                        www.cpguru.com Level 4

                        Im still not a 100% clear if you are viewing the published project or viewing from within Captivate. When you say "preview it in my browser" - are you hitting F12 from Captivate to preview it in the browser?

                         

                        You need to publish your project completely (Shift + F12) in order for the preloader to work. It should work just fine - select a preloader in the preferences start and end options. Publish your project. View the published project and that should work. If not then try a different preloader.

                         

                        /Michael

                         


                        Click here to visit my Captivate blog

                        1 person found this helpful
                        • 9. Re: Preloader
                          tommoon Level 1

                          ok, I'll give it a shot and let you know how it works.  Thanks!!