23 Replies Latest reply: Oct 10, 2012 7:10 AM by LightbIT Branched to a new discussion. RSS

    AE hangs at "Initializing Media Core"

    ingvarai Community Member

      I have successfully installed the Production Premium suite. In the beginning, all apps ran fine. I automatically updated the suite, and AE now is version 9.0.2. I could use all applications in the suite, including After Effects.

       

      Then something happened. First I updated my NVIDIA driver (GeForce 7600GT), then I installed Reg Giant Key Correct Pro. After that, AE just won't start anymore. When loading, it stops at "Initializing Media Core".

       

      I have uninstalled RedGiant Key Correct Pro.

      I have rolled back my NVIDIA driver.

      I have uninstalled my NVIDIA driver.

      I have reinstalled After Affects from the DVD.

      I have updated AE once more (the DVD has version 9.0, the update is 9.0.2)

      I have always rebooted when uninstalling / installing.

       

      No matter what I do - AE is stuck shortly after it loads, at "Initializing Media Core", and I have to kill it using Task Manager in Windows.

      I run Vista 64bit with 8Gb RAM, and  NVIDIA GeForce 7600GT.

       

      ingvarai

        • 1. Re: AE hangs at "Initializing Media Core"
          Adolfo Rozenfeld Adobe Employee

          I know that Magic Bullet is a Red Giant product which installs a Media Core component which produces this problem.

          Maybe Key Correct Pro does that too (or you have Magic Bullet?) Make sure you uninstall using an installer rather than delete the plug-ins manually.

          If it's not that, then you could have a third party codec that could be causing problems.

          • 2. Re: AE hangs at "Initializing Media Core"
            Mylenium CommunityMVP

            Maybe Key Correct Pro does that too

             

            No, not that I'm aware of. There was a compatibility fix for CS4, but the plug-in itself is not hardware accelerated and should not interfere with MediaCore. Magic Bullet products (Looks, Colorista, Frames, Steady) however might. It's definitely worth checking. In addition, I recommend checking the Media Cache. perhaps there are just some damaged conform files in there.

             

            Mylenium

            • 3. Re: AE hangs at "Initializing Media Core"
              ingvarai Community Member

              Case closed!

               

              Here is my approach:

              I logged in as another user, then After Effects started with no problem (I should have done this before testing anything else!)

              I switched back to my standard user, and inspected the user data.

              Here is the folder C:\Users\MyName\AppData\Roaming\Adobe\After Effects\9.0

              Here is the file which causes the error: Adobe After Effects 9.0 MC Prefs

              This is an XML file, without the xml extension

              Here is the culprit, the offending line:

              <ML.Audio.ASIOHost.DriverName>ASIO 2.0 - ESI 1010</ML.Audio.ASIOHost.DriverName>

              ESI 1010 is my breakout sound card, and ASIO is a common popular sound driver (very low latency).

               

              Conclusion:

              I did too many things at the time, Updating NVIDIA, Installing Key Correct Pro - AND - edited the sound preferences in AE. I apologize to Red Giant for suspecting their software!

               

              Comments:

              I wonder why AE can't tackle this. By installing CS4 Production Premium, my hard drive's real estate was set back 20Gb (!). Still this application is not equipped with software that will circumvent these kind of problems when loading, no message telling me that "Sound driver preferences are bad - default preferences are used instead". It just hangs!!

               

              ingvarai

              • 4. Re: AE hangs at "Initializing Media Core"
                Mylenium CommunityMVP

                AE uses WDM sound. It should be able to handle ASIO in a WDM wrapper, but it cannot handel it natively. I think Premiere and Sounbooth do, though. So in essence AE crashed due to attempting to initialize the card incorrectly. I'm sure this can be remedied by enabling some compatibility switch in the audio config, also, but if removing the line does the trick, success can hardly be argued. As they say: Fortune favors the bold!

                 

                Mylenium

                • 5. Re: AE hangs at "Initializing Media Core"
                  ingvarai Community Member

                  I did it wrong when trying to tweak the sound settings in AE. I am used to this, other applications do not recognize my ESI 1010. AE, however, does, and it uses WDM and my ESI 1010, in accordance with the settings. Total silence reigns at the moment though, so I'll have to find out why AE is so quiet.

                  Anyhows - thanks to all of you who responded, without this response I would probably not have come up with the idea of switching user. Having switched user, and seeing that AE started fine, the rest was a matter of time to narrow down the problem.


                  ingvarai

                  • 6. Re: AE hangs at "Initializing Media Core"
                    kirktapzilog Community Member

                    I found a way to solve this problem easily!

                     

                    While you are stuck at "initializing media core", you can end the process of the quicktime server. afterwhich, adobe cs5 will proceed as usual

                    windows 7, x64

                    • 7. Re: AE hangs at "Initializing Media Core"
                      balizumba Community Member

                      I found the latest AE 10.0.1  update, installed it. It read that everything installed correctly. Then  upon loading up AE, I still get the following messages one after the  other:

                      "After Effects Warning: Failed to initialize mediacore"
                      "After Effects Warning: MediaCore is not correctly initialized"
                      "You have at least one output module that refers to a missing ouput plug-in. Please check your Output Module Templates"

                       

                      The  bizarre thing is that before, I had to do a system restore because of  my Nvidia Card (which is still not working), I had this same problem but  I fixed it when I installed AE updates directly from within the  program. Then I was able to import all media files. but now i cannot  import any audio or video or Adobe Premiere project files!!

                       

                      Any ideas? Re-install AE?

                       

                      thanks

                      Z

                      • 8. Re: AE hangs at "Initializing Media Core"
                        tabilog Community Member

                        NOPE!!haha its simple just install the older versions of quicktime like Quick Time 7 and beloW! or just run adobeqt32server.exe at startup even if your quicktime is updated or you can create a shortcut adobeqt32server.exe and run it!, for Newbies the directory of adobeqt32server.exe  is  C:/Program Files/Adobe/Adobe After Effects CS5/Support Files/32/Adobe QT32 Server.exe Thank you!

                        1 more you can create a easy shorcut! first open notepad and paste:

                         

                        @echo off
                        start "" "C:\Program Files\Adobe\Adobe After Effects CS5\Support Files\32\Adobe QT32 Server.exe"
                        start "" "C:\Program Files\Adobe\Adobe After Effects CS5\Support Files\AfterFX.exe"

                         


                        and save it as Adobe After Effects CS5.bat dont save it as txt file save it as bat file ok!

                        • 9. Re: AE hangs at "Initializing Media Core"
                          reformationdesigns Community Member

                          I did all of these things and the problem still doesn't get fixed.

                          • 10. Re: AE hangs at "Initializing Media Core"
                            nightssky117 Community Member

                            I am now having this problem with CS5 not 5.5 AE wont load . Was just useing it.. Then had to force quit now it hans on this spot..

                            Need help.

                            • 12. Re: AE hangs at "Initializing Media Core"
                              KYLam2011 Community Member

                              I have the same problem here, but today I update my Avast free to internet security, the problem disappeared.

                              • 13. Re: AE hangs at "Initializing Media Core"
                                Rick Gerard CommunityMVP

                                Anti Virus software from just about every manufacturer has been known to cause intermittent problems, slowdowns, and crashes at various times for many Windows users.

                                 

                                The problems have not been limited to Adobe. Any app that writes to disk in the background can be broken by anti-virus software. If a windows machine I was on suddenly stopped working properly or failed to install an app that's the first place I'd look. The second, video codecs. The third, fonts. They all can easily go screwy and foul things up.

                                • 14. Re: AE hangs at "Initializing Media Core"
                                  sullivanconsultants Community Member

                                  Same problem. I renamed the C:\Program Files\Adobe\Adobe After Effects CS4\Support Files\(Media Core plug-ins)\Common to common1. Started and gave a Media Core error but still loaded. I renamed the folder to Common and failed again. My solution was to uninstall Quick Time.

                                   

                                  Emmet Sullivan

                                  Sullivan UnLimited

                                  www.sullivanunlimited.com

                                  • 15. Re: AE hangs at "Initializing Media Core"
                                    SwimEvanSwim Community Member

                                    The easiest way to fix this is to Delete your user account and create a new one. In my experience the problem exists somewhere in the usuer preferences. I can log out and sign in as a different user and AE fires right up. This does seem to be an issue with AE not working well with Adobe QT32 Server.exe. I reinstalled AE, removed all plugins, un-installed anre reinstalled quicktime, all to no avail. The best and easiest solution has been to: 1) move all stuff you want from your user account (my documents, my music folder, desktop, Outlook database files etc) to a renamed folder on your C drive. 2) Create a new User account. 3) Delete your old user account. 4)login as new user and copy over any old files you saved on your C drive. This should wipe any problems that were burried in the user acount.

                                    • 16. Re: AE hangs at "Initializing Media Core"
                                      devmeena1992 Community Member

                                      Just turn off the firewall of your antivirus.

                                      In my case McAfee firewall was creating the problem.

                                      • 17. Re: AE hangs at "Initializing Media Core"
                                        reformationdesigns Community Member

                                        I dont have an antivirus program installed.  i've tried turning off all

                                        firewalls it still does it.

                                         

                                        And Adobe is strangely absent from all of these discussions.

                                         

                                        $800 software and they can't afford to pay for someone to do tech support?

                                         

                                        Really?

                                        • 18. Re: AE hangs at "Initializing Media Core"
                                          StardogChampion Community Member

                                          As with most other CS5 problems, it's 100% Quicktime related. Fact. Look no further.

                                           

                                          Will Adobe fix it? No.

                                          • 19. Re: AE hangs at "Initializing Media Core"
                                            Todd_Kopriva Adobe Employee

                                            > And Adobe is strangely absent from all of these discussions.

                                             

                                            I don't understand what you mean by this. Two Adobe employees have responded on this thread alone.

                                             

                                            > $800 software and they can't afford to pay for someone to do tech support?

                                            You can contact Adobe Technical Support here:

                                            http://www.adobe.com/support/contact

                                            • 20. Re: AE hangs at "Initializing Media Core"
                                              Todd_Kopriva Adobe Employee

                                              > As with most other CS5 problems, it's 100% Quicktime related. Fact. Look no further.

                                               

                                              One of the possible causes for this is related to QuickTime---specifically QuickTime failing to load a bad third-party codec (usually an AVI importer). See the second solution on this page for details:

                                              http://kb2.adobe.com/cps/857/cpsid_85711.html

                                              • 21. Re: AE hangs at "Initializing Media Core"
                                                RxFroniter001 Community Member

                                                I had this problem too sometimes when opening After Effects...when it got stuck at "Initialising MediaCore" i 'End Proccess' from task manager ans restart AE but still had th same problem...so what i did after that was I try switching off my Internet or disconnect from the Internet and try relauch AE..and it works!!

                                                • 22. Re: AE hangs at "Initializing Media Core"
                                                  CRinker Community Member

                                                  I did find one other easily fixed cause that locked up my AE CS6. In looking through System Preferences, the Perian utility that has DivX and other tools for media playback luckily indicated that "It was installed twice". I removed the duplicate install and voila, everything back to normal. Hope this helps someone as it was very frustrating!

                                                  • 23. Re: AE hangs at "Initializing Media Core"
                                                    LightbIT Community Member

                                                    I had this same problem, and fixed it by removing some SAN networking software. It definetly has something do a conflict with some other app that is using your network.