1 Reply Latest reply on Sep 8, 2009 6:14 AM by Xavier Agnetti

    building the Flex PMD source code

    TexMags

      Hi, I looked at the developer documentation on how to build it locally at http://opensource.adobe.com/wiki/display/flexpmd/Developer+documentation .

       

      When I run step 7: mvn package

      I get this error

       

      [INFO] Scanning for projects...
      [INFO] ------------------------------------------------------------------------
      [INFO] Building Maven Default Project
      [INFO]    task-segment: [package]
      [INFO] ------------------------------------------------------------------------
      [INFO] ------------------------------------------------------------------------
      [ERROR] BUILD ERROR
      [INFO] ------------------------------------------------------------------------
      [INFO] Cannot execute mojo: resources. It requires a project with an existing pom.xml, but the build is not using one.
      [INFO] ------------------------------------------------------------------------
      [INFO] For more information, run Maven with the -e switch
      [INFO] ------------------------------------------------------------------------
      [INFO] Total time: < 1 second
      [INFO] Finished at: Tue Sep 08 07:41:12 CDT 2009
      [INFO] Final Memory: 3M/6M
      [INFO] ------------------------------------------------------------------------

       

      I have these versions:

      Maven version: 2.0.10
      Java version: 1.6.0_10

       

      Does it need to be maven 2.2.0 or later or Java 1.5 or is there some other dependency I'm missing? The documentation doesn't mention the maven implementation flex-mojos so I am assuming that is not needed.

       

      TIA,

      Magnus