8 Replies Latest reply on Sep 14, 2009 11:03 PM by Mylenium

    I can't uncheck "leave all attributes" in the precompose window

    Dj burner

      Hi guys, I can't uncheck "leave all attributes" box in the pre-compose window. even after I double check it, I check the other option, I've tried with Crtl+Click over the check box, and so on and nothing works cause the option remains checked.

       

      Somebody knows what would be the reason, is it a Bug or a Program Feature?. I use After Effects CS3 8.0.0.298
      It would be so appreciated any hint on this problem. Tnxs.

        • 1. Re: I can't uncheck "leave all attributes" in the precompose window
          Mylenium Most Valuable Participant

          What exactly are you trying to pre-compose? If the box is unavailable, there is some feature active that prevents it from working. This could be anything, but most often it is some layer that is being referenced by anotehr layer not being included in the selection. Likewise, certain time-remapping techniques, continuous rasterization and a few otehr features can trigger this behavior. Hard to tell. Please provide screenshots of the timeline structure (attach using the camera icon) and more details.

           

          Mylenium

          • 2. Re: I can't uncheck "leave all attributes" in the precompose window
            Dj burner Level 1

            Hi Mylenium, now is vice verse, I can’t uncheck “move all attributes into the new composition”. Sorry my AE is on Spanish, but it's almost the same thing. To illustrate my case I made a new composition and dragged a photo named “City” into it (I haven't applied any effect or such to it, I've just changed its scale a little bit in order to have an attribute).

             

            Precompose_01.jpg

             

             

             

            Now I selected this photo and I've pressed Crtl + Shift + C (or from the menu) and when I’m into the Precompose window I can’t uncheck “move all attributes…” and just leave “Leave all attributes...” that is exactly what I want to do. I’m forced to choose both. ("move all attributes" check box appears already selected as soon as I chose Precompose)

             

             

            Precompose_02.jpg

             

            I’m forced to choose both.

             

            Precompose_03.jpg

             

             

            I can't uncheck "move all attributes into the new composition" check box even with a double click on it.

             

             

             

            It’s weird and it sounds like a bug instead of a programs feature.

             

            What would you think?

             

            Thanks for your help.

            • 3. Re: I can't uncheck "leave all attributes" in the precompose window
              Dj burner Level 1

               

               

              --------------This is just an Idea------------------

               

              If this is a bug, I’ve figurate out a way to avoid it since I noticed that AE always remember my last setting in most of its windows like cameras, render option, precompose, and so on even when I restart the program. If I can do something to make the option "move all attributes into the new composition" unavailable, right when I go for the real thing AE will remember it and then It will allow me to check just the "Leave all attributes" because it will be already selected.

               

              I always can do that when the program runs this bug. My question is: What I have to do (anything) to force "move all attributes into the new composition" unavailable?.

               

              I resolved my first problem (uncheck "Leave all atributes") doing this because you cannot select it when you have more than 2 layers selected. But I don’t know a way to make "move all attributes into the new composition" unavailable.

               

              Hope I made myself clear.

              • 4. Re: I can't uncheck "leave all attributes" in the precompose window
                Mylenium Most Valuable Participant

                I'm honestly stumped. You should never even be able to select both options. So yes, this is a bug of some sort. What kind of JPEG is it? Perhaps something going on with CameraRAW/specific color profiles. Can you post the image and your test project?

                 

                Mylenium

                • 5. Re: I can't uncheck "leave all attributes" in the precompose window
                  TimeRemapper Level 4

                  Maybe try resetting your preferences?

                  • 6. Re: I can't uncheck "leave all attributes" in the precompose window
                    Adolfo Rozenfeld Adobe Employee

                    What happens if you go ahead and Apply? Maybe there's a rederaw problem and the UI is showing both options, but the last pciked option is the one that gets applied?

                    • 7. Re: I can't uncheck "leave all attributes" in the precompose window
                      Dj burner Level 1

                       

                      Thanks to everyone for your help & time .

                       

                      Steve: I’ve already cleaned them all up and the problem still there (Crtl+Shift+Alt before AE starts).

                       

                       

                      Adolfo: I’ve did it and the precomposition “Leave all the attributes*” but never “Move all the attributes” what is exactly what I want to do now..

                       

                       

                      Mylenium: Now I’m back with the first problem: I can’t uncheck “Leave all attributes in*…” cause it appears already selected. BTW That was the last option that I had selected by the moment when this bug ran therefore I’m 100% sure that this is a bug problem. As you said, it’s impossible to leave both option selected, it doesn’t make any sense at all.

                       

                       

                      I made the same project with the same picture because all of the sudden "Leave all atributtes" just freezes out. As you can see the problem comes sometimes with “Leave” sometimes with “Move”, all depends on which was the last option that I had selected by that moment.

                       

                      New_Precompose_01.jpg

                      Now is "Leave" the one who doesn't want to leave (If I can allow me a wordplay cause I'm about to cry, )

                       

                      New_Precompose_02.jpg

                       

                      Then when I want to just select "Move", "Leave" just still selected.

                       

                      New_Precompose_03.jpg

                       

                       

                       

                      What would it be?

                       

                      Now, since I’m pretty sure that this is a bug, I know that I can fool it by forcing the program to leave unavailable one option with a "whatever" move, therefore the other option will be the preselected option the next time so I would be able to do my selection right. I can unavailable " Leave" by just select 2 layers, but...

                       

                      What could I do to leave "Move" unavailable?.

                       

                      Once again thanks all of you for your help & time.

                       

                      Here’s my project and picture, just change to "Copia de Project_City.jpg" the extension to aep. (The system doesn't allow me to upload those files).

                      • 8. Re: I can't uncheck "leave all attributes" in the precompose window
                        Mylenium Most Valuable Participant

                        I have just tried this on my system here at work and it works without a hitch. Therefore I tend to think that this indeed may be a redraw or mouse interaction problem of some sort. I recommend as a start, that you change the Windows theme. Right-click on your Desktop, chose Properties and set the Theme to Windows Classic. This wil ldisable a few fancies that may cause the erratic behavior. if that doesn't solve it, investigating your graphics card settings is the next thing. Install a newer driver or, which is more likely the issue here, adjust the settings. I could well imagine, that e.g. something is up with NVidia desktop manager trying to position the dialog or hardware acceleration does not correctly handle the panel.

                         

                        Mylenium