14 Replies Latest reply on Jul 24, 2008 7:49 PM by nowherecreative

    Dreamweaver Template Problem

    nowherecreative
      Now that I finally have my CSS layout, I need it as a template because I am going to be applying it to about 100 pages. I can save the file as a template just fine, but as soon as I add an editable region (to my main content div) I am no longer able to preview my work in my browser even though it is still visable in the design view of Dreamweaver. Even when I upload the page to the server all I get is a plain white page. I've attached the code. Thanks in advance for any help!
        • 1. Re: Dreamweaver Template Problem
          Level 7
          > Now that I finally have my CSS layout, I need it as a template because I
          > am
          > going to be applying it to about 100 pages.

          Bad plan. Applying Templates to pages with existing content is tedious and
          tricky.

          And, the code you show below is NOT a properly created DW Template file.

          How did you create this "template"? The correct way is to first create the
          page, then use FILE | Save as Template, and give the template a name. DW
          will know what extension to use, and where to save it. Then you would add
          your editable regions.

          --
          Murray --- ICQ 71997575
          Adobe Community Expert
          (If you *MUST* email me, don't LAUGH when you do so!)
          ==================
          http://www.projectseven.com/go - DW FAQs, Tutorials & Resources
          http://www.dwfaq.com - DW FAQs, Tutorials & Resources
          ==================


          "nowherecreative" <webforumsuser@macromedia.com> wrote in message
          news:g6a6bs$h0v$1@forums.macromedia.com...
          > Now that I finally have my CSS layout, I need it as a template because I
          > am
          > going to be applying it to about 100 pages. I can save the file as a
          > template
          > just fine, but as soon as I add an editable region (to my main content
          > div) I
          > am no longer able to preview my work in my browser even though it is still
          > visable in the design view of Dreamweaver. Even when I upload the page to
          > the
          > server all I get is a plain white page. I've attached the code. Thanks in
          > advance for any help!
          >

          • 2. Re: Dreamweaver Template Problem
            nowherecreative Level 1
            Well the pages aren't created yet, this is an entirely new site. I will be adding in all the fresh content once I get this working. I went ahead and deleted that template (the code I posted) and tried again using the method you mentioned. I am still getting a blank page when I preview or upload to the server. I've attached the new code.
            • 3. Re: Dreamweaver Template Problem
              Hi, I have not taken the time to look into your code but to make a region editable within a template is fairly straight forward. I manually input the codes in the code view for better accuracy.

              <div >

              <!-- TemplateBeginEditable name="MainText" --> This is just some text <!-- TemplateEndEditable -->

              </div>

              You have to insert the middle code within your template page. The code has to be inside the div tags you want to make editable. Be sure to name it uniquely from other editable regions. Hope this works.


              • 4. Re: Dreamweaver Template Problem
                Level 7
                > Well the pages aren't created yet, this is an entirely new site

                That's much better, although 100 pages is still right on the cusp of
                Template usability UNLESS you are also integrating server-side includes in
                your methodology.

                I use the following scheme....

                First, I mentally separate the page layout into three sections:

                1. Stuff that will not change for the life of the site (i.e., the basic
                structural elements)
                2. Stuff that *could* change from time to time (e.g., navigation elements,
                burst advertisements, section-specific navigation, etc.)
                3. Stuff that *will* change from one page to the next

                Then I create a template containing all class1 elements. Next I create
                server-side include files containing all class 2 elements and place them on
                the template as needed. Note - some of the class 2 elements may be
                "section-specific elements", and their placement on the template will be
                subject to the next item. Finally, I insert editable regions to cover the
                class 3 items, INCLUDING the section-specific navigation.

                This allows me to just cookie-cut the rest of the site. I estimate that
                even for fairly large sites, about 80% of my work goes into planning and
                creating this template file.

                > I am still getting a blank page when I preview or upload to the
                > server.

                You are previewing with the F12 key or the Preview icon in DW? Are you
                previewing the Template page, or a child page? Do you have preview with
                temp files enabled in your preferences? When you "upload to the server",
                are you uploading and then browsing to the *.dwt page? Have you tried
                spawning a child page from this template, and then previewing/uploading the
                child page?

                --
                Murray --- ICQ 71997575
                Adobe Community Expert
                (If you *MUST* email me, don't LAUGH when you do so!)
                ==================
                http://www.projectseven.com/go - DW FAQs, Tutorials & Resources
                http://www.dwfaq.com - DW FAQs, Tutorials & Resources
                ==================


                "nowherecreative" <webforumsuser@macromedia.com> wrote in message
                news:g6a7oi$ie9$1@forums.macromedia.com...
                > Well the pages aren't created yet, this is an entirely new site. I will be
                > adding in all the fresh content once I get this working. I went ahead and
                > deleted that template (the code I posted) and tried again using the method
                > you
                > mentioned. I am still getting a blank page when I preview or upload to the
                > server. I've attached the new code.
                >

                • 5. Re: Dreamweaver Template Problem
                  nowherecreative Level 1
                  Thank you, that is exactly what I did, since it is a CSS layout I am only working in the code view. My trouble is once I add in the editable region, I only get a blank white page when I preview it in the browser or upload it to the server.
                  • 6. Re: Dreamweaver Template Problem
                    Level 7
                    This problem is unrelated to how you insert the editable regions....

                    --
                    Murray --- ICQ 71997575
                    Adobe Community Expert
                    (If you *MUST* email me, don't LAUGH when you do so!)
                    ==================
                    http://www.projectseven.com/go - DW FAQs, Tutorials & Resources
                    http://www.dwfaq.com - DW FAQs, Tutorials & Resources
                    ==================


                    "nowherecreative" <webforumsuser@macromedia.com> wrote in message
                    news:g6a8pb$jjr$1@forums.macromedia.com...
                    > Thank you, that is exactly what I did, since it is a CSS layout I am only
                    > working in the code view. My trouble is once I add in the editable region,
                    > I
                    > only get a blank white page when I preview it in the browser or upload it
                    > to
                    > the server.
                    >

                    • 7. Re: Dreamweaver Template Problem
                      nowherecreative Level 1
                      "You are previewing with the F12 key or the Preview icon in DW? Are you
                      previewing the Template page, or a child page? Do you have preview with
                      temp files enabled in your preferences? When you "upload to the server",
                      are you uploading and then browsing to the *.dwt page? Have you tried
                      spawning a child page from this template, and then previewing/uploading the
                      child page?"

                      Yes, I am previewing with the F12 key, I've tried both the Template page and the child page and unfortunately I get the same result, same thing when they are placed on the server. I've browsed to both the .dwt page and the page the template is applied to. Now I am having issues with all the code not rendering properly in Firefox ... I'm sorry I'm so new to all of this hand coding!
                      • 8. Re: Dreamweaver Template Problem
                        Level 7
                        * Do you have preview with temp files enabled in your preferences?

                        > same thing when they are placed on the server

                        Please post a link to both the template page and the child page that you
                        have uploaded.

                        > I'm sorry I'm so new to all of this hand coding!

                        Everybody gotta be somewhere. But so far, there is no hand coding, you
                        know? 8)

                        --
                        Murray --- ICQ 71997575
                        Adobe Community Expert
                        (If you *MUST* email me, don't LAUGH when you do so!)
                        ==================
                        http://www.projectseven.com/go - DW FAQs, Tutorials & Resources
                        http://www.dwfaq.com - DW FAQs, Tutorials & Resources
                        ==================


                        "nowherecreative" <webforumsuser@macromedia.com> wrote in message
                        news:g6aako$liv$1@forums.macromedia.com...
                        > "You are previewing with the F12 key or the Preview icon in DW? Are you
                        > previewing the Template page, or a child page? Do you have preview with
                        > temp files enabled in your preferences? When you "upload to the server",
                        > are you uploading and then browsing to the *.dwt page? Have you tried
                        > spawning a child page from this template, and then previewing/uploading
                        > the
                        > child page?"
                        >
                        > Yes, I am previewing with the F12 key, I've tried both the Template page
                        > and
                        > the child page and unfortunately I get the same result, same thing when
                        > they
                        > are placed on the server. I've browsed to both the .dwt page and the page
                        > the
                        > template is applied to. Now I am having issues with all the code not
                        > rendering
                        > properly in Firefox ... I'm sorry I'm so new to all of this hand coding!
                        >
                        >

                        • 9. Re: Dreamweaver Template Problem
                          nowherecreative Level 1
                          Okay I am going to post the links, and I've discovered that the template files only don't work in IE7 ... however, they show up just fine in Firefox ... BUT ... Firefox is not rendering the CSS correctly, it looks terrible and I have no idea why or what I did wrong in the coding.

                          Link to Template Page: http://www.colonybeachresort.com/CSS_Testing/templates/main_template.dwt
                          Link to Page with Template Applied: http://www.colonybeachresort.com/CSS_Testing/templates/new.html
                          Link to Regular Page (no template): http://www.colonybeachresort.com/CSS_Testing

                          Thanks again!
                          • 11. Re: Dreamweaver Template Problem
                            Level 7
                            OK - there are plenty of errors there.

                            First, get rid of this -

                            <?xml version="1.0" encoding="utf-8"?>

                            You do not need it.

                            Next, fix this -

                            <style type="text/css" media="all">@import url(css/master.css);</style>
                            <style>
                            <!--
                            BODY {background-attachment: fixed;}
                            </STYLE>
                            <!-- InstanceBeginEditable name="head" -->

                            Note that you have left an opening comment tag unclosed. That's why you are
                            seeing blank pages - everybody thinks that the rest of the page is a
                            comment. Also, your <style> tag is invalid until you add type="text/css" to
                            it.

                            --
                            Murray --- ICQ 71997575
                            Adobe Community Expert
                            (If you *MUST* email me, don't LAUGH when you do so!)
                            ==================
                            http://www.projectseven.com/go - DW FAQs, Tutorials & Resources
                            http://www.dwfaq.com - DW FAQs, Tutorials & Resources
                            ==================


                            "nowherecreative" <webforumsuser@macromedia.com> wrote in message
                            news:g6aeft$pni$1@forums.macromedia.com...
                            > Woops, the page with the template applied is:
                            > http://www.colonybeachresort.com/CSS_Testing/new.html

                            • 12. Re: Dreamweaver Template Problem
                              nowherecreative Level 1
                              Perfect! Thank you so much! It is now working. Now on to why it is not working correctly in Firefox ... would you happen to know?
                              • 13. Re: Dreamweaver Template Problem
                                Level 7
                                Does the page validate?

                                --
                                Murray --- ICQ 71997575
                                Adobe Community Expert
                                (If you *MUST* email me, don't LAUGH when you do so!)
                                ==================
                                http://www.projectseven.com/go - DW FAQs, Tutorials & Resources
                                http://www.dwfaq.com - DW FAQs, Tutorials & Resources
                                ==================


                                "nowherecreative" <webforumsuser@macromedia.com> wrote in message
                                news:g6ahbq$sqi$1@forums.macromedia.com...
                                > Perfect! Thank you so much! It is now working. Now on to why it is not
                                > working correctly in Firefox ... would you happen to know?

                                • 14. Re: Dreamweaver Template Problem
                                  nowherecreative Level 1
                                  The CSS page validates 100%, however I didn't get a chance to check the HTML page so as soon as I get into work tomorrow morning I'll find out. :)