3 Replies Latest reply on Sep 15, 2009 1:15 PM by Sean_Wilson

    Trouble with Video File (wmv) Path - Director Keeps Reverting to Old Path

    djDaemon

      I'm looking for some assistance in getting a video to play direct-to-stage within my movie once it is burned to CD.

       

      What I've found is that using a relative path should work, and my movie should find the video files just fine.  However, I'm having much difficulty with this.  I've been able to modify the "filename" of the video cast member to a relative path (@Video\videofilename.wmv), and have the property inspector reflect this change.

      Untitled-13.jpg

      However, once I save, publish and check to ensure it works, the movie begins looking for the file in the original location.  This has happened several times.  I've changed the properties for the cast member in the cast, as well as for the cast member on the stage (not sure if their properties are linked, so after a few troubled outcomes, I attempted to change both).  No matter what, the path in the Filename field reverts back:

      CastMemberProperties01.jpg

      I've even gone so far as to remove the videos from the cast and stage, then add them back again, using only the relative path in the filename field, to no avail.  The result is always the same - once I save & re-publish, the filename reverts back to the absolute path.  To say the least, this is frustrating. 

       

      Thanks very much in advance for your help.

       

      - B

        • 1. Re: Trouble with Video File (wmv) Path - Director Keeps Reverting to Old Path
          Sean_Wilson Adobe Community Professional

          The 'pathname' operator should be considered the character combination "@:" or "@\" or "@/", so your path should be "@\Video\videofilename.wmv"

           

          As you say, this shouldn't give problems. If it persists there are a couple of options. Use the prepareMovie handler to set the searchPathList and/or set the member.filename property before the "Where is ..." dialog appears:

          on prepareMovie
            _player.searchPathList.append(_movie.path & "Video")
            -- member("wmv").filename = "@\Video\videofilename.wmv"
          end
          
          • 2. Re: Trouble with Video File (wmv) Path - Director Keeps Reverting to Old Path
            djDaemon Level 1
            The 'pathname' operator should be considered the character combination "@:" or "@\" or "@/", so your path should be "@\Video\videofilename.wmv"

            Wow.  Yeah, I suppose not everything you read on the internet is true.    Thanks for that - it solved the path reversion problem.  However, the projector still couldn't find the video files even after this fix.

             

            Of course, your second suggestion worked swimmingly.  Thanks a million!  Though I must admit, being a complete neophyte with regard to script and the like, I'm not sure exactly what your solution does, in the technical sense.  If you find the time, an explanation would be wonderfully helpful.  If not, no worries.

             

            Thanks again.

             

            - B

            • 3. Re: Trouble with Video File (wmv) Path - Director Keeps Reverting to Old Path
              Sean_Wilson Adobe Community Professional

              I'm not sure there's much I can add to the documentation around the key words in what I posted, but I'll give it a shot:

              prepareMovie is a movie-level event (it isn't sent to sprites - they aren't even initialised yet) that runs as the Director file is starting up. It's a good place to run code before anything is visible on the stage. The searchPathList is a list of folders Director will look in for external assets before it throws up the "Where is ..." dialog. That is, if it can't find a linked file where it expects it will look through all the folders in this list and only if it can't be located in one of these will the dialog appear. Does that help?