5 Replies Latest reply on Sep 16, 2009 8:14 AM by kglad

    button

    jaysondking

      I am having a problem where my buttons on main timeline are working fine. When I create a button within a movieclip layer (a page importeded from  Photoshop as a movieclip) the button is not working once I leave. It doesn't show as a working button when I select Enable simple buttons, when I preview or publish as HTML. The thing is, it is a button, it has an instance name, is that weird blue color... and it works fine when I am double clicked into that movieclip layer. I also tried common library buttons and they work fine until I leave that layer as well, also tried it within other layers and creating a new file and doing it... all no success!

       

      Please help, almost all my hair is pulled out!!!!!!!

       

      I also posted in another area, so if you read already I apologize... I just need to get this figured out before a deadline...

       

      Thanks

       

      Jayson

        • 1. Re: button
          kglad Adobe Community Professional & MVP

          are any mouse handlers defined for the movieclip that contains your button?

          • 2. Re: button
            jaysondking Level 1

            Yes, there are... I even went back just now and rewrote a smaller one for a single button to see. I entered...

             

            stop();

             

            //handle events for buttons...

            photosoeight.addEventListener(MouseEvent.CLICK, clickSection);

             

            function clickSection(evtObj:MouseEvent) {

            //trace shows what's happening... in the output window

            trace("The Photosoeight button was clicked");

            //go to the cestion clicked on...

            gotoAndStop("photos2008");

            }

             

            I do not get it... I know it is possible because I am following the Lynda lesson and it works fine there. The buttons all work fine inside the movie clip, there is a layer for buttons, a layer for actionscript, timelines... etc... Soon as I leave that movie clip and go back to scene 1 they no longer show as functioning buttons? Or in the preview?

            • 3. Re: button
              kglad Adobe Community Professional & MVP

              do you see that trace output?

              • 4. Re: button
                jaysondking Level 1

                No, there isn't a trace output because it is like the button does not exist when i preview the swf file. There are trace outputs for the similar code for the main timeline because the buttons work. I cannot click, rollover, anything... the buttons created within the movie clip layers.

                • 5. Re: button
                  kglad Adobe Community Professional & MVP

                  you create a movieclip.  on that movieclip's timeline you create a button, give it an instance name and assign mouse listener code for that button on the movieclip's timeline.  you then add that movieclip to the main timeline, give the movieclip an instance name and assign it mouse listener code on the main timeline.  is that all correct?

                   

                  well, that can't be correct because that's what you should do and that would work without problem.  so, what did you do that was different?