1 Reply Latest reply on Sep 16, 2009 5:47 PM by Jeff Swartz

    Windows XP SP3. Unable to install AIR, any help?

    djaffinito

      Hello,

       

      I'm trying to install AIR on my Windows XP SP3 workstation.  I had 1.5.0.7220 installed, but the application wanted to update it so I downloaded the newest runtime.  Tried to upgrade it but it wouldn't upgrade, kept saying Error 0. So I tried using this note: http://kb2.adobe.com/cps/403/kb403150.html to remove it, but it wasn't in my Add/Remove programs, so I found this command you can run to uninstall it:

       

      E:\Apps\Adobe Air>AdobeAIRInstaller.exe -uninstall

       

      but it fails

       

      E:\Apps\Adobe Air>Uninstalling Adobe AIR (all versions)
      failed (consult log)

       

      so I checked the log in %temp% and this is all it says

       

      Error 1714. The older version of Adobe AIR cannot be removed.  Contact your technical support group.  System Error 1612.
      === Logging stopped: 9/16/2009  14:04:24 ===

       

      Then I found a note saying to create the file .airinstall.log in your User dir and try reinstalling.  This is what is in that log:

       

      UI SWF load is complete
      starting uninstall
      Beginning install
      Uninstalling product w/ GUID {00203668-8170-44A0-BE44-B632FA4D780F}
      Error occurred; beginning rollback: [ErrorEvent type="error" bubbles=false cancelable=false eventPhase=2 text="1612" errorID=0]
      Rollback due to error complete
      error during install: [ErrorEvent type="error" bubbles=false cancelable=false eventPhase=2 text="1612" errorID=0]
      runtime install entering error state: [ErrorEvent type="error" bubbles=false cancelable=false eventPhase=2 text="1612" errorID=0]
      begin quitting

       

      So in a last (probably stupid..) ditch effort, I deleted everything in my registry that I thought had to do with AIR and all the adobe air directores in my users folder and program files and ran CCleaner.

       

      It didn't help, in fact it's exactly the same errors..

       

      Any help?