2 Replies Latest reply on Apr 26, 2016 7:19 AM by zahida21695666

    Flex hangs with user operation is waiting for building workspace to complete message

    David Tames Level 1

      My Flex Builder (recently installed under Mac OS X 10.5.8) constantly hangs when launching an application or trying to quit. It has become useless.

       

      I get the message: 'the user operation is waiting for "building workspace" to complete.' when I try to run an application (only one so far) or quit.

       

      I can't get beyond this and the percentage progress does not change, even after a long time.

       

      If I try running a software update, it hangs on the quit.

       

      I tried uninstall and reinstall, to to avail.

       

      Any ideas on how to resolve this?

        • 1. Re: Flex hangs with user operation is waiting for building workspace to complete message
          Eric Anderson Level 1

          I have a post on my blog about this issue but i'll post it here.

           

          This morning I ran the Flex compiler on my project and the compiler hung. I was confused as to why my project would not compile, considering the fact that exactly 3 hours ago I was running the compiler like nobody’s business, building projects left and right; I digress. So immediately, I clicked on the progress tab and a window popped up titled User operation is waiting. Well after searching Google yet again for a solution to another Flex Builder 3 issue, I had, you guessed it, no luck finding an answer.

          After spending an hour or so trying to fix Flex Builder, I found out that this problem usually occurs if you have big scale projects or too many projects in general opened all at once. In addition, if you have the refresh projects automatically workbench preference turned on it will occur as well.

          What I did to fix this problem is simply deselect the refresh projects automatically option in the Flex Builder preferences panel then I closed the project that I was working on and closed out Flex Builder. Once I reopened Flex Builder 3 and my project, everything worked like before. Another issue solved