3 Replies Latest reply on Sep 26, 2009 7:46 AM by bsubito

    Problems with “no color” in the “Fill and Stroke”

    bsubito

      I am having problems with “no color” in the “Fill and Stroke” function of Flash CS4 Pro.

       

      I had been using CS4 for 10 days and everything worked fine. Then I tried experimenting with various color combinations (along with “no color”) for “Fill and Stroke” for a simple button. Suddenly CS4 locked up on me while I was working with the “color panel”. A second color panel appeared in the upper left corner and the program was not responding. All I could do was to end the CS4 task.

       

      After that, whenever I created even a simple rectangle, at first the colors would appear as indicated for “Fill and Stroke”, but when I selected the object to see its properties, either the stroke or the fill color box would have a red slash line, indicating a “no color”, and I couldn’t select the color box to change it using the ink bottle tool, although the other box worked fine.

       

      Rebooting did not help. So I uninstalled CS4 (and didn’t keep the preferences), rebooted, then reinstalled it. The problem was still there. Logging on as another user didn’t help. I tried restoring the Windows system to before I installed CS4 and resinstalling it and that didn’t work. I have a disfunctional CS4 now and I don’t know what to do to fix it. Please help me. Thank you.

        • 1. Re: Problems with “no color” in the “Fill and Stroke”
          jendehaan Level 4

          Have you updated flash to 10.0.2?  Have you played around with a bunch of different selections, objects, and so forth to see if this box is always incorrect?  I think there's some particular selection (order of selecting things, and so on), where the color swatches in one location don't work as expected. However, it should not happen all the time and from what I recall it was fairly easy to work around (I can't even figure out what this was - so probably not it, as it seems hard to run into or perhaps now fixed).

           

          Also make sure you have the stroke selected - if you don't have everything selected, either the fill or stroke will show no color and dim depending on the selection.

          • 2. Re: Problems with “no color” in the “Fill and Stroke”
            bsubito Level 1

            I will try the upgrade to 10.0.2, thank you. I always set the fill and stroke first before drawing. Also, even when there is color at first for say the stroke, I can't change the color and increasing the stroke size doesn't change the object.

             

            What is most confusing is how the same problem retains even after restoring earlier and reinstalling. I wonder if there is some special file or registry saved somewhere?

            • 3. Re: Problems with “no color” in the “Fill and Stroke”
              bsubito Level 1

              Jdehann,
              Thank you! Thank you! Thank you!
              I just installed the update and it fixed the problem. I didn't know about the update. You saved me from having to rebuild my operating system and hours of work. Thank you for taking the time to respond with thoughtful ideas. May you have great blessings come back to you. You're great!
              Sincerely, Bob