2 Replies Latest reply on Jul 6, 2010 6:03 AM by shinank

    upgrading to QTP v10 with Flex?

    vondalyn

      We've been successfully using QTP 9.2 and 9.5 with our Flex application.  We'd like to upgrade to QTP 10, but when I tried running our existing scripts using QTP v10 they fail on the Login screen.

       

      I'm unable to record and I'm also unable to add Flex objects to the QTP Object Repository.

       

      Can anyone tell me if the Flex QTP addin works with QTP v10.  Or if someone else has successfully been able to migrate their 9.2/9.5 scripts/Obj Rep to v10.  If you were successful, what did you do?

        • 1. Re: upgrading to QTP v10 with Flex?
          QAParul

          Hi,

           

          Even i'm facing lot of problems in using flex addin.I first tried to use flex addin 3.0 with QTP 9.5+IE 7 combination.I tried using it on flexstore (flex sample application by Adobe).The addin was able to spy correctly on flex objects but it was not recording the objects.I some where read that flex addin 3.0 has a bug and that it does not work with QTP 9.5 +IE 7 combination.And that adobe has come with a fix with flex addin 4.0.I tried using flex addin 4.0 with QTP 9.5 +IE 7 and it worked successfully( both record and play)  on flexstore.

           

          But when i use the same addin with QTP 10.0 +IE 8 combination , flex addin 4.0 is not able to recognize objects of flexstore ( sample application).It simply shows flex objects as winobject.

           

          My question is does flex addin 4.0 support QTP 10+IE 8 combinaton or have i not installed the addin correctly .But the same addin worked wonderfully on 9.5 +IE 7 combination.

           

          Can someone answer this query ASAP as i need this information urgently.

           

          Thanks

          --Parul

          • 2. Re: upgrading to QTP v10 with Flex?
            shinank

            Parul,

            I had the exact same symptoms you are experiencing and as soon as I used the Flex 4 add-in instead of the Flex 3 add-in everything started to work.

             

            I was using:

            Flex 3 Builder / 3.2 SDK

            Flex 4 QTP add-in

            QTP 10

            IE 8

            Win XP

             

            Have you ran any updates/patches on your QTP 10 installation?