4 Replies Latest reply on Sep 9, 2010 8:10 AM by LearnProDave

    FLV files set for streaming video not working

    rponce

      Hi,

      I have been using Captivate 4 for some time using imported FLV and progressive download options. Playback is too slow, so I am trying to use a streaming service (Limelight Networks Flash Video Streaming Service). I took an existing Captivate project, uploaded the FLV file to the streaming service and select the following in Captivate under the Flash Video tab:

       

      Video type: Streaming video

      Server URI:  points to server, app, instance from provider (eg: rtmp://xxx.net/yyy/zzz...)

      Stream name: filename.flv

       

      I publish (htm and swf files are local, flv is on the streaming provider's machine) and try to playback. Captivate loads and after a time I get an error saying that a script is causing the flashplayer to run slowly (version 10). It then locks up (tested in IE, Firefox and Chrome). I've changed options in Captivate such as Flashplayer version (from 8-10) and buffer delay, to no avail. No video played. Previously the video played in the project as a progressive download.

       

      Help appreciated!

        • 1. Re: FLV files set for streaming video not working
          Ashwin Bharghav Level 2

          Hi there,

           

          I tried the same setting and it works for me. The only difference was that i gave the stream name without the .flv extension

           

          Try your setting without the .flv extension for the file name.

           

          Let me know if it works.

           

          -Ashwin

          • 2. Re: FLV files set for streaming video not working
            rponce Level 1

            Hi Ashwin,

             

            This still hasn't worked for us. We have been given a server name in this format: rtmp://server.name.net/ and an application name in the format app/name, which together form a url:   rtmp://server.name.net/app/name

             

            Then I have the move file in a subdirectory (/test) from this base url and finally the filename: myvideo.flv

             

            So putting it together I have tried in Captivate:

             

            Streaming

            field 1: rtmp://server.name.net/app/name

            field 2: /test/myvideo.flv

             

            or

             

            rtmp://server.name.net/app/name/test

            myvideo.flv

             

            or

             

            rtmp://server.name.net/app/name

            /test/myvideo

             

            and other combations of these three. I've eliminated the flv extension, tried with and without preceding (/) and trailing (/)  (eg: /test/... vs test/... or).

             

            None of these seem to work. I can play the flv directly using a client called WIMPY so I know the streaming service works. With that client I enter a fully qualified path such as: rtmp:/server.name.net/app/name/test/myvideo.flv  and it works flawlessly.

             

            Thanks for your assistance.

            • 3. Re: FLV files set for streaming video not working
              nick1245

              WE are having TERRIBLE problems with a CDN service using extension .flv.smil.

               

              We can use the service when the SWF file is created through FLASH but we cannot then get it to show video controls unless we use the published HTMNL page so embedding the video in the actual web page has not worked. When created with CAPTIVATE thye swf file appears but the video will not stram from the folder reserved for FLASH streaming. When using the published HTML all works fine. If anyone knows how to get around these issues please let me know.

              • 4. Re: FLV files set for streaming video not working
                LearnProDave

                Hi Guys,

                 

                Have just managed to get this working.

                 

                Here is an example of how I did it:

                 

                URI: rtmp://fms.example.site.net/.../directory

                Stream Name: myvideo

                 

                Note that I have removed the trailing slash in the first part, and the .flv from the stream name.

                 

                I hope that this helps

                 

                Dave