3 Replies Latest reply on Oct 1, 2009 11:26 AM by RedOctober57

    Unable to start a new FB4 project

    RedOctober57 Level 1

      I'm a complete beginner at CF, CFB, and FB.  I'm trying to follow along in the video:

       

      http://www.adobe.com/devnet/flex/articles/fcf_flex_for_coldfusion_developers.html

       

      However, no matter what I do in the "New Flex Project" dialog, I get this error message, and can't get past it.

       

      Invalid root. The WEB-INF/flex folder must contain either flex-config.xml or services-config.xml.

       

      The file flex_config.xml actualy exists, and is in the correct folder.

       

      (See my settings in the attached image)

       

      Note that according to a video that I watched previously, by Ben Forta, he said to change the project root for his example to:

       

      C:\ColdFusion9\wwwroot

       

      Which I did.  In case that makes any difference.

       

      Also, in the video http://www.adobe.com/devnet/flex/articles/fcf_flex_for_coldfusion_developers.html

      it just jumps right into a dialog titled "Select Service Type".  I don't know how to invoke this dialog.  The video doesn't show.  None of the buttons in the "Data Services" tab work because it complains that I need to have a project selected.  I can't create a project because of the error above.  What am I doing wrong?  Thanks in advance.

       

      HOLD THE PHONE!   I was just high lighting the error message and file name when I noticed the difference.  The new project dialog is looking for flex-config, when the FB installer, or something, put flex_config... underscore versus dash.  Ok, if this is the problem... should I change the file name to suite FB?  If I do, will I wreck something else?