1 Reply Latest reply on Oct 2, 2009 9:46 AM by Mylenium

    Unable to open linked files in new CS3 install

    John_MaxE

      One of my clients just purchased a new PC (Dell Inspiron 537S) with Windows Vista Home Premium to replace his old Inspiron 530 (also running Vista HP). After installing CS3 Design Studio and attaching an external drive loaded with his file archive, all of his Illustrator files which include links load with the following error:

       

      "An error occurred trying to read the linked file "file.xxx". Choose Repair to locate the missing file, Replace to select another file or Ignore to leave the link unchanged."

       

      This shouldn't be unusual, if the path to a linked file has changed, you'd need to point the link to the new path, but clicking Repair or Replace and browsing to the linked file (which invarably is in the same directory as the .ai file, and is usually a .psd which opens just fine in Photoshop) just cycles back to the same error message, ad infinitum. After about 30 tries, I got one of the links to load correctly, resaved the document, thinking that would repair it, but when I opened it again, got the error.

       

      These files were created on multiple computers, and none of the other computers (all with CS3) have ever had any trouble opening them. This despite the drive letter on the external drive being unstable on the old system (would often be J:, K: or L:, and images always worked).

       

      Any new .ai files we create on this file which have links all work fine.

       

      Manually replacing the links in a file is not an option for two reasons:

       

      1. There are thousands of .ai files in this archive, and re-linking images in them will take weeks.

       

      2. It simply doesn't work. I tried ignoring the error on one file to load it, and re-linking the .psd backgrounds to re-save it, and the images still didn't load after re-linking them.

       

      I have already tried doing a factory-restore of the system and reinstalling CS3, making sure that there were no errors in the install. What else might cause this behavior, and how can I resolve it?

        • 1. Re: Unable to open linked files in new CS3 install
          Mylenium Most Valuable Participant

          What else might cause this behavior, and how can I resolve it?

           

          Outdated permissions on the files from your old computer. Right-click, Properties --> Security --> Advanced, disable Inherit settings from parent folders, chose to copy. After that, delete outdated security keys and assign current ones. You may even need to go so fart as to Take Ownership of some files to correctly restore the new system's default security settings.

           

          Mylenium