0 Replies Latest reply on Oct 2, 2009 11:52 AM by qazwsxedc111

    Is this a PlotChart+CategoryAxis bug?

    qazwsxedc111

      The following code unexpectedly produces a vertical line that passes through the first data point - anyone knows why?

       

      <?xml version="1.0" encoding="utf-8"?>
      <mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

       

          <mx:Script>
          <![CDATA[
         
              import mx.collections.ArrayCollection;
             
              [Bindable]
              private var stockDataAC:ArrayCollection = new ArrayCollection( [
                  { Date: "25-Jul", Open: 40.55,  High: 40.75, Low: 40.24, Close:40.31},                     
                  { Date: "5-Aug", Open: 36.61,  High: 37, Low: 36.48, Close:36.86} ]);
          ]]>
          </mx:Script>
         
          <!-- UI Section -->
          <mx:Panel title="My First Dynamic Chart">
              <mx:PlotChart dataProvider="{stockDataAC}" showDataTips="true" >
                 
                  <!-- Define the axes -->
                  <mx:horizontalAxis>
                      <mx:CategoryAxis
                          categoryField="Open"/>
                  </mx:horizontalAxis>
                 
                  <!-- Define the series -->
                  <mx:series>
                      <mx:PlotSeries
                          displayName="Series 1"
                          xField="Open"
                          yField="Close">
                      </mx:PlotSeries>
                  </mx:series>
             
              </mx:PlotChart>
          </mx:Panel>
         
      </mx:Application>